Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Windows 7 on a new harddrive, and have attached my old vista installed hd via an external dock.

I'm trying to copy the contents of my old hd across, but hitting problems when trying to browse to the Users/MyUser folder.

I get the following message:

You dont have permission to access this folder click continue

After clicking continue, nothing happens.

I've tried Right Clicking -> Security and setting the owner of the folder to my account, but to no avail.

Any suggestions on how to access this folder?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You need to allow yourself full access to the hard disk.
The following procedure will only work if you're logged in as an administrator.

The first step is to take ownership of the files.
Start a Command Prompt box (cmd) as administrator, and enter:

takeown /f /r X:\

Then give yourself full rights on the file:

cacls X:\*.* /T /G username:F

For more info on cacls see:
Security from the command line with CACLS.

If you're having problems using cacls, a more evolved Visual Basic script exists:
Xcacls.vbs to modify NTFS permissions.

share|improve this answer

This is because your security settings are wrong.

You need to do two things. First one is changing owner of files (as you already did) and second one is adding permissions for that user in security tab.

If you just want some copying and you will not boot Windows from that drive, you can add Full rights to Everyone.

share|improve this answer

Have you tried setting up an account on your new Windows 7 install with the same username and password as the old Vista machine?

share|improve this answer
1  
Not going to work, because the account SID is not going to be the same. The account name is just for human consumption, NTFS ACEs apply to SIDs. –  ThatGraemeGuy Oct 26 '09 at 13:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.