Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to fix an issue with Windows registry and services. I tried running sfc command but this is the error message I get?

C:\Windows>sfc /scannow

Beginning system scan.  This process will take some time.    

There is a system repair pending which requires reboot to complete.  Restart
Windows and run sfc again.

C:\Windows>

But I have rebooted several times since this message first appeared, and I even tried running the command in safe mode and in console mode but I still get the same message. How do I get rid of it?

There is this file in winsxs folder: C:\Windows\winsxs\cleanup.xml

This is it's content:

<?xml version='1.0' encoding='utf-16'?>
<PendingTransaction >
    <POQ postAction="NoReboot">
        <DeleteFile path="\??\D:\$$DeleteMe.CbsMsg.dll.01c85bd2f5893b40.0000"/>
    </POQ>
</PendingTransaction>

Could this be something? Is this the cause? Is it safe to delete this file?

Update

I tried renaming it but the operation failed.

I ran the explorer.exe with elevated privileges and navigated to the location. I got the UAC confirmation prompt and then the error below.

Destination Folder Access Denied
You need permission to perform this action

How do I rename or delete this file? Do I need to use cmd or be in safe mode to do it?

Update 2

I started safe mode with command prompt and tried taking ownership of the file and then renaming it. Rename failed.

C:\Windows\winsxs>ren cleanup.xml cleanup.xml.old
Access is denied.

C:\Windows\winsxs>takeown /f "cleanup.xml"

SUCCESS: The file (or folder): "C:\Windows\winsxs\cleanup.xml" now owned by user
 "mycomputername\username".

C:\Windows\winsxs>ren cleanup.xml cleanup.xml.old
Access is denied.

C:\Windows\winsxs>

I also issued following command.

C:\Windows\system32>icacls "C:\Windows\winsxs\cleanup.xml" /grant username:F
processed file: C:\Windows\winsxs\cleanup.xml
Successfully processed 1 files; Failed processing 0 files

C:\Windows\system32>cd ..\winsxs

C:\Windows\winsxs>ren cleanup.xml cleanup.xml.old
Access is denied.

C:\Windows\winsxs>

It still won't allow me to rename it. I issued these last two commands in normal Windows mode. Does it matter?... I will try a reboot.

share|improve this question
    
Problem solved, by performing a repair install. –  sammyg Jun 18 '13 at 10:25
add comment

2 Answers

This command is supposed to do it.

dism.exe /image:C:\ /cleanup-image /revertpendingactions

But this only works in Windows 7 or newer. I don't have the dism.exe tool in Windows Vista. I just thought I would share it with those who find this question and who do have Windows 7. I was of course unable to test this myself, but this guy says he was able to remove this annoying error message out of the world. So it might be worth a try.

share|improve this answer
add comment

look in the registry under SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing if you see a key called RebootPending. This is the place where Windows also checks if there is a pending reboot.

share|improve this answer
    
In HKLM (local machine)?... –  sammyg Jun 17 '13 at 9:46
    
Yeah, I have HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\RebootPending and it contains only the default string value, and it's not set to anything. Should I set it to 0 or something? Or maybe remove the key? –  sammyg Jun 17 '13 at 9:49
    
"Cannot delete RebootPending: Error while deleting key." –  sammyg Jun 17 '13 at 10:18
1  
take ownership of the key: winaero.com/comment.php?comment.news.210 and now delete it. –  magicandre1981 Jun 17 '13 at 14:40
    
Thanks! I will download that reg tool, I'm sure it will come in handy sometime. So it's probably good to have it in the toolbox. –  sammyg Jun 18 '13 at 10:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.