Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a really odd problem. I had a raspbian installation on a raspberry pi running mysql and mysql workbench. Everything was working fine, then I tried to import a backup db on to the pi using mysql workbench on my windows machine. My windows machines workbench stopped responding so I ended up killing the process. I the started workbench on the pi and went to the server admin, where the process details usually show was a large red rectangle with a cross through it. So I restarted the pi and since then I can not get mysql workbench to start up. I formatted the sd card and reinstalled my backup (on which I know for certain that mysql workbench was working) but again when I tried to run it the splash screen appears and then vanishes but workbench does not start. I then used a different card which also had mysql workbench installed and still it did the same, so I uninstalled mysql workbench and reinstalled it but no luck.... So I tried the cards in a different pi and yet still the same result. Even more strange is that when I run sudo mysql-workbench from the terminal it runs fine but there are no database instances showing (I know that there were instances saved on the backup installation).

However if I connect to the pi using windows mysql workbench I can connect to the database server without issue.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.