Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am looking to access a second HDD in my PC, it is formatted as NTFS and I the data on the second HDD cannot be replaced so I need a method that will not delete the data on the HDD.

fdisk -l command output about second HDD

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x60ed0890

I am running the following the command to try and mount the drive:

mount -t ntfs /dev/sdb /home/colin/media

I am getting the following error when I run the command:

NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a 
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

How can I mount the HDD without deleting the data currently on the HDD?

share|improve this question
    
Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? (hint hint - try sdb0 or sdb1, do a ls /dev/sdb* to see which there are on the disk). –  Breakthrough Jun 16 '13 at 20:55
    
The output from fdisk -l shows sda1, sda2, sda5. How can I tell which of these relates to HDD #2? –  Colin747 Jun 16 '13 at 20:57
    
The output is: /dev/sdb /dev/sdb1 –  Colin747 Jun 16 '13 at 21:03
    
Try mounting sdb1 instead and it should work. sdb usually refers to the hard drive as a device, sdb1 refers to just that physical/logical partition. I believe fdisk only shows any mounted partitions as well as drives (although there may be an option to change this behaviour). –  Breakthrough Jun 16 '13 at 21:04
    
Just to clarify try mounting sdb1? –  Colin747 Jun 16 '13 at 21:05

1 Answer 1

up vote 3 down vote accepted

You need to mount the logical/physical partition, and not the drive. sdb refers to the hard drive as a device, whereas sdbX (where X is an integer starting from 0) refers to the logical/physical partitions on the drive.

You can see which partitions are on the drive by doing (may need sudo):

ls /dev/sdb*

From the output, you should be able to determine which partition to mount. You can then mount as you were doing, but with sdbX instead (e.g. assume the partition is sdb1, and may need sudo):

mount -t ntfs /dev/sdb1 /home/colin/media
share|improve this answer
    
That worked, thanks! –  Colin747 Jun 16 '13 at 21:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.