Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this mp4 video file on one of my portable hard drives, which could not be copied.

It could be played perfectly directly from my portable hard drive but when I copy it to my internal hard drive, I will encounter an error something like Could not read file, I/O device error, can't complete the request. Error code: 1117 on Windows 7 (The error message is not in the exact words when it was displayed, because I run a Chinese system. But the gist is there.), when around 112 MB of this file is processed. The file has 249MB in total.

And I also tried on Mac, and tried using FastCopy on windows, the same problem occurs.

Is there a way to rescue this file?

share|improve this question
1  
Seems like it's time to run a chkdsk /R and probably replace the hard drive. –  Werner Henze Jun 17 '13 at 9:23
    
Yes, let me try chkdsk /R. I am thinking of replacing it, but I want this file back.. –  larryzhao Jun 17 '13 at 9:26
    
FYI, looking up that error code on UK system you get: "The request could not be performed because of an I/O device error." you might have some luck googling that. –  snowdude Jun 17 '13 at 11:32
    
@WernerHenze chkdsk /R did the trick, thanks, you may answer it, and I will accept that, for the future. –  larryzhao Jun 17 '13 at 13:38
add comment

1 Answer

up vote 0 down vote accepted

Seems like the hard disk is defect and should be replaced as soon as possible.

You might try to run a chkdsk /R to recover bad sectors.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.