Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a very similar problem to Matt's problem here. I had 2 Barracuda XT 3TB SATA drives in my desktop PC running Windows 7 Ultimate 64-bit. I sold the PC but kept the drives and bought a USB 3.0 enclosure so I can access my data from my laptop. The laptop is running the same version of Windows 7. The computer recognises the external drive but it does not appear in Windows Explorer. Windows Disk Management says I must initialize the disk.

I have tried it with both 3TB drives from the PC with the same result. I tried it with a new drive and it works fine so the enclosure is not at fault. I also tried them in another enclosure with the same result.

Any ideas? Will I lose everything on the drive if I let Windows initialize it? Matt doesn't let us know what happened in the end with his drive...

PS The desktop PC had an Asus P6T Deluxe motherboard and used the latest Intel Matrix Storage Manager.

share|improve this question
    
Do not initialize the disk, you will lose all the data. You only need to initialize a disk that is brand new. –  BroScience Jun 17 '13 at 16:13

2 Answers 2

Are you sure you are providing enough power to the USB enclosure? If it has an external power supply make sure you use it. If it does not, make sure you plugging it into a powered USB port.

share|improve this answer
    
Thanks BroScience. The USB enclosure has its own power supply which I am using and the drives are spinning up just fine. I think the issue might be that these were internal SATA drives connected to an Asus P6T Deluxe motherboard using Intel Matrix Storage Manager drivers. And now they are connected via USB 3.0 to a laptop without these drivers and somehow the partitions are just not accessible. I even tried using Gpart but still cannot access the partitions. –  Frank Black Jun 18 '13 at 7:44
    
Honestly, it should not make any difference. –  BroScience Jun 19 '13 at 13:42

Your drive can't be accessed from the USB dock most likely due to an outdated firmware. Please check your dock's official site to see if there is a firmware update. =I have a Xigmatek Secure III that faced the exact same thing. After a firmware update, the drive now mounts on OS X just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.