Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is one of the standard issue vodafone routers. So i set up web-server on my laptop, and it is accessible to the internet now.

However I need to be able to access it from my machine using the public address. But I just cannot find where to enable nat loopback. I looked for options in both regular and advanced user logins (web interfaces). So I suppose the last option is telneting into it, and using commands to do it.. but I don't know how to access it (cant find the credentials).

http://rhiggins.sdf-eu.org/blog/index.php?entry=entry110722-164625

In above link it says that i can find this info in configuration file, but anyone could tell me how to access it?

And then what commands should I use to enable the NAT loopback?

share|improve this question

2 Answers 2

It may or may not be supported. I have gotten around this in the past by ssh tunneling through a local socks proxy or by using one of the many free proxies available online.

share|improve this answer

As mentioned by @Scandalist, it may or may not be supported on your router. However, if it is, try the commands recommended here. My router was different than the one listed there but the commands worked the same.

First, telnet into the router (most platforms will have this available in CLI) It may require a user/pass which should be the same as your web interface credentials:

telnet <router ip>

Then enable loopback:

ip nat loopback on

Then exit telnet:

exit

Some routers allow you save the setting. I tried doing this on my router using some commands that it displayed in its "help" but couldn't get it to work.

I ended up adding the telnet stuff into a script on another machine with a cron job every 5 minutes, this way if the router is ever loses power I will telnet back into it after it comes back up and re-enable the loopback. The script is a one liner:

(echo <password>; echo "ip nat loopback on"; sleep 1; echo "exit" ) | telnet <router_ip> <username>
share|improve this answer
    
Thanks for a detailed answer, but did not work. I am starting to suspect that as Scandalist said already it is simply not supported :) –  galdikas Jul 1 '13 at 18:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.