Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Linux Mint 15 64bit. My laptop has a Geforce 640M Optimus card, so I installed bumblebee according to the installation instructions (Basic Setup). Using optirun to run programs (e.g. Steam) works as intended. However, certain programs like Skype, now show

error while loading shared libraries: cannot open shared object file: No such file or directory

when not run with optirun. I do not want Skype to run on the dedicated card, so this is an issue. The following files are found on my system:


If I run

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/ skype

all works well.

This is the output for update-alternatives --query i386-linux-gnu_gl_conf:

Name: i386-linux-gnu_gl_conf
Link: /etc/
 i386-linux-gnu_xorg_extra_modules /usr/lib/i386-linux-gnu/xorg/extra-modules
Status: auto
Best: /usr/lib/nvidia-304/
Value: /usr/lib/nvidia-304/

Alternative: /usr/lib/i386-linux-gnu/mesa/
Priority: 500
 i386-linux-gnu_xorg_extra_modules /usr/lib/i386-linux-gnu/xorg/x11-extra-modules

Alternative: /usr/lib/nvidia-304/
Priority: 9701

I tried updating the alternatives to the mesa one, but this does not fix the problem.

What do I have to do to get GL support without optirun?

Thank you for any hints!

share|improve this question
But if You'll add LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/ to ~/.bashrc and ~/.profile does it work after a reboot? – Adobe Jul 6 '13 at 17:53

1 Answer 1

up vote 4 down vote accepted

Okay, I found the fix, someone else posted it on askubuntu:

If you haven't yet installed bumblebee, simply install libgl1-mesa-glx:i386 before you install bumblebee and you should be fine.

If you have already installed bumblebee, install libgl1-mesa-glx:i386 and then reinstall bumblebee-nvidia. It worked for me! (I used sudo apt-get --purge autoremove bumblebee-nvidia, then just reinstalled it.)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.