Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I download a Joomla extension to my Mac (e.g. http://www.admiror-design-studio.com/admiror-joomla-extensions/admiror-gallery) I can't upload it via the Package File option because my Mac sees the download as a folder.

How do I get it to stop doing that? It's driving me insane!

share|improve this question

migrated from stackoverflow.com Jun 17 '13 at 22:58

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 2 down vote accepted

You can either re-compress it using right-click, compress. Or turn off 'auto open save files' in safari preferences.

share|improve this answer
    
Fantastic answer my friend, and welcome to SO! –  Michael Perrenoud Jun 15 '13 at 15:36
    
You're welcome and thanks! –  user2396565 Jun 17 '13 at 13:36

I often have this problem with Wordpress plugins.

When you download a compressed file (e.g. .zip, .gz, etc.) OS X tries to be useful and expands it with the archive manager. Then all you need to do is right click the folder (or CTRL Click) and hit compress. You should java a ZIP file you can then upload without doing anything to it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.