Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Opening any of the audio properties dialogs takes 2 minutes and 5 seconds every time. There aren't other tasks that take an unreasonable amount of time. It's something specific to the Sound properties dialog. If I restart my computer, it will open immediately for the first day or 2.

It's likely a driver issue. I have an AMD graphics card with sound output (through HDMI), a Realtek audio chip on the motherboard, a USB microphone, and USB headphones. Is there a way to determine which one of these is misbehaving? Or a way to figure out what's holding things up when it's waiting?

share|improve this question
1  
use ProcessMonitor to look what causes the delay. Mark showed it here in this video at TechEd: channel9.msdn.com/Events/TechEd/NorthAmerica/2013/WCA-B306 – magicandre1981 Jun 18 '13 at 8:25
    
This was the direction I was looking for. I haven't been able to figure out yet. It's a lot of information to take in. – Sean Jun 20 '13 at 1:58
up vote 6 down vote accepted

http://www.overclock.net/t/903497/opening-playback-devices-is-slow suggests disabling audio device(s) in Device Manager.


Edit by Sean (the OP):

This article does not seem to be completely related. Their issues were with crossfire and sound over HDMI. However, disabling the "AMD High Definition Audio Device" in the Device Manager did work for me.

share|improve this answer
2  
That sounds very promising, especially since the OP has mentioned that they are using AMD and HDMI audio. However, instead of just posting a link, you should summarize the page here—the edit in the first post is sufficient. ;-) – Synetech Aug 26 '13 at 1:47
    
Added a bit to the answer describing the solution. It did work for me. I would still like to know a way to diagnose this. – Sean Sep 4 '13 at 22:51

I fixed it with ATI HDMI Audio Device driver, tested in ATI/AMD 7850 and R9 270x from realtek for Windows 7 and 8.1.

share|improve this answer

I have the same problem and updating the audio driver from AMD didn't work, and in fact the update caused HDMI audio to stop working.

After reverting to the previous driver version I noticed that the problem is caused by using the HDMI audio when the TV is turned off. If I remember to switch it back to "Speakers" when the TV is turned off, it doesn't "break".

share|improve this answer
    
Updating the driver didn't work for me either. Rebooting the computer would make it work for a time. Removing the unused drivers solved the issue for me. I've since switched to Windows 10 and don't have the issue anymore, although I couldn't tell you if they're related. – Sean May 10 at 12:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .