Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a spreadsheet that I created in Excel 2011 for the Mac. In it, I am able to create a dynamic print range and it works well.

However when I open the spreadsheet in Excel 2010 for Windows, I look at the named ranges and my dynamic print range has becomes static.

The worksheets that I am printing contain formulae in cells down to row 101. I calculate the last row that has printable data and place that in a named range called Last_Row. I then refer to Last_Row when I calculate the print area in the named range "Print_Area".

As I said, on my Mac when the number of rows with printable data changes, so does the number of pages printed. In Excel 2010, however, the range "Print_Area" becomes static and doesn't update as the number of printable rows changes.

Has anyone had this issue before, or know the solution?

Update

I also have the same behaviour in Excel 2013.

The formula that I am using is:

=OFFSET('Run1'!$A$1,0,0,'Run1'!Last_Row,9)

The value "Last_Row" is also a named range and it works without any problems on any version of excel.

share|improve this question
add comment

1 Answer

I have the same issue in Win Excel 2010 but only sometimes. Some workbooks retain the dynamic formula, others convert to static. I just discovered this yesterday so don't have more data yet on full behavior.

OK, here's an answer I've uncovered that does not solve the problem but does avoid it:

Don't use the Print Preview option anywhere.

This option consistently converts a worksheet's Print_Area expressed as a formula to its absolute range. I tested this repeatedly using Adobe vs Print Preview; Adobe does not result in conversion but Print Preview does. I'm assuming hard-copy printing (for those who use paper) works the same as Adobe.

share|improve this answer
    
This is not an answer to the question asked. This is merely a comment. Please us the comment function in the future. –  Uwe Plonus Jun 19 '13 at 14:42
    
Apologies. I missed the Comment option. I've edited my "answer" with a real answer, I believe. –  tesuji Jun 19 '13 at 15:43
    
Welcome to Super User! This is a Q&A site, so posts that don't actually answer the question get removed. Once you have participated for a bit and earned enough reputation you will be able to post comments (like this one) if you have other information to add, e.g. workarounds or related questions,. Find out more about Super User on the about page and in our help center. –  Daniel Beck Jun 19 '13 at 19:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.