Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

everyone!

I have a booting USB stick with some iso-image, based on Arch Linux. It loads through efi and then comes to Grub 1.99, where I can choose the iso images. I can load them without any problems, but before I see the menu of the Grub some error messages appear:

error: "prefix" is not set

error: efidisk read error

USB stick is formatted in FAT32 and has a partition table msdos.

Here is my /boot/grub/grub.cfg

insmod video
insmod font
insmod jpeg

insmod gfxterm

set prefix=/boot/grub/grub.cfg

loadfont /boot/grub/unicode.pf2

set gfxmode=auto
terminal_output gfxterm

background_image /boot/grub/background.jpg
set default=0

set timeout=10

set menu_color_normal=white/black set menu_color_highlight=black/light-gray

menuentry "image.iso" {
set isofile="/images/image.iso" loopback loop $isofile set root=(loop) linux /isolinux/vmlinuz isofile=$isofile splash quiet initrd /isolinux/initrd }

These settings works without any problems. At least, I can see my background image and the styles has been changed.

I also checked from the Grub shell the parameters

root=hd2,msdos1 //means that I have a correct path, otherwise actually it doesn't boot.

I tried different versions of this prefix // /boot/grub/ // /boot/grub/grub.cfg // /efi/boot/

I would be glad to hear what can be the problem:)

p.s. Was reading also that can be sth with GPT partition table, but in this case it doesn't boot with my computer.

Thanks for helping.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.