Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This should probably go into the question about Windows Annoyances, but can anyone explain why this happens, and how to fix it?

I right-click on a folder, select properties, and uncheck the Read-only. Click on OK. I get a confirmation with the option to apply changes to this folder only, or include subfolders and files. I select the latter, and click OK.

Go back to properties, and it's still showing up as Read only. Why? I can't see any files that are still read-only

share|improve this question
add comment

3 Answers

up vote 6 down vote accepted

This issue is described in KB326549: You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, or in Windows Vista

The solution given there is to simply use the command-line attrib command to remove the attributes, like so:

attrib -r -s "c:\somepath\my readonly folder"
share|improve this answer
1  
Note the read-only status of a folder generally won't cause any issues and can usually be ignored. –  Pedro Jul 16 '09 at 21:40
    
Its interesting that they chose the read-only attribute to hint to Explorer to load desktop.ini for that folder. That emphasizes that normal applications really are not supposed to pay attention to it. –  RBerteig Jul 16 '09 at 23:47
add comment

Type Win+R cmd ENTER to get a shell. In the shell, type the following:

> cd "C:\Path\To\Read-Only\Folder"
> attrib -R /S /D

The /S and /D are needed to recurse into and remove read-only attribute from subfolders.

share|improve this answer
add comment

http://windowsitpro.com/article/articleid/24940/why-cant-i-remove-the-read-only-flag-from-a-windows-xp-or-windows-2000-folder.html

  • Start a registry editor (e.g., regedit.exe).
  • Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer subkey.
  • Select New -> DWORD Value from the Edit menu.
  • Enter a name of UseSystemForSystemFolders and press Enter.
  • Double-click the new value, set it to 1, and click OK.
  • Close the registry editor.
  • Reboot the machine for the changes to take effect.

Once you've done this you should be able to change your folder permissions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.