Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed this guide to compile QEMU so that I could run a Raspberry Pi Archlinux image in it - which I learned how to do in this guide.

I'm trying to run x-server on the virtualized Archlinux image, but to do so, I must have a graphics device. I installed some generic drivers (i.e. Vesa) for now, but my QEMU isn't showing any graphics devices to be available.

As a startup parameter, I tried -vga cirrus which gave me the error:

Error: Cirrus VGA not available

I then tried to have QEMU emulate a different graphics device using the -vga std parameter, but then got this error:

Error: standard VGA not available

Where do I go from here? I have a gut feeling that this issue is due to the fact that I compiled QEMU myself for ARM. I've looked up the error message, but I can't seem to find anything relevant to my issue.

FWIW:

  • The host is Ubuntu x64 12.04
share|improve this question
up vote 2 down vote accepted
+100

VGA is a (more or less) x86-specific standard. As such, it is not available on ARM. A similar question was answered here: You can obtain graphics support using the ARM Versatile baseboard.

Seeing how your guide already sets the -M versatilepb option, you should be good to go as is. The kernel you're using already has support for the graphics solution on the emulated board.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .