Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Tab key has suddenly started acting strange in Matlab (R2011b) editor. It's working backwards!

Pressing it doesn't add tab spaces and whenever I press it after a couple of spaces, the cursor comes back to the first place.

I've checked the keyboard preferences and everything seems fine. Tab action is assigned to the Tab key. Also, turning the autocomplete on/off or changing the Tab size didn't have any effect on it.

Anybody has any idea how to fix this?

Note: it's working fine in other applications and also in the console window.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I found the fix for my problem. It was caused by what is called Emacs-Style Smart Indenting.

To disable it:

File → Preferences → Editor/Debugger → Tab → "Emacs-style Tab key smart indenting".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.