Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a NFS share mounted on /.

/srv/nfs/gentoo/i686-gentoo  192.168.1.0/255.255.255.0(all_squash,ro,no_subtree_check)

Running mount with any "squash" option will prevent the client from running /bin/mount.

bash: /bin/mount: Permission denied

I can mount filesystems, but running mount with no arguments results in "Permission denied". This is causing problems with systemd and is interfering with the boot process. I have to manually mount whatever options that are in the fstab file and resume the boot process.

If I specify no_root_squash, then /bin/mount runs fine. How do I "squash" the NFS share while being able to run /bin/mount?

share|improve this question
up vote 0 down vote accepted

Apparently, Gentoo's /bin/mount is -rws--x--x by default. Changing it to -rwsr-xr-x fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.