Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just unpacked my new Sony Vaio, with windows 8 pro installed. Everything is nice, so I tried setting my power management options. The "When I close the lid" option only list:

  • Hibernate
  • Sleep
  • Shutdown

The "Do nothing" option is not present.

I've seen loads of stuff on google where people ask or explain how to set this option to "Do nothing", but in all my power plans this option is absent...

Can I use a tool to prevent this, or is there a way to force windows to show me this option (and that it actually works)?

UPDATE powercf /q guid gives me this output:

Subgroup GUID: 4f971e89-eebd-4455-a8de-9e59040e7347  (Power buttons and lid)
    GUID Alias: SUB_BUTTONS
    Power Setting GUID: 5ca83367-6e45-459f-a27b-476b1d01c936  (Lid close action)
      GUID Alias: LIDACTION
      Possible Setting Index: 000
      Possible Setting Friendly Name: Sleep
      Possible Setting Index: 001
      Possible Setting Friendly Name: Hibernate
      Possible Setting Index: 002
      Possible Setting Friendly Name: Shut down
    Current AC Power Setting Index: 0x00000000
    Current DC Power Setting Index: 0x00000000

Other sections have different enumerations where 000 stands for No action

share|improve this question
1  
I've even tried to override the settings using gpedit.msc, but that doesn't work. –  Jaap Jun 18 '13 at 18:58
    
Try powercfg -attributes SUB_BUTTONS LIDACTION -ATTRIB_HIDE from an elevated command prompt, reboot and check. Also see if there are any driver and especially BIOS updates available. –  Karan Jun 18 '13 at 19:58
    
That doesn't work unfortunately, please see the updated output –  Jaap Jun 21 '13 at 12:22
    
Googling around a bit, it seems other SONY vaio's seem to have this issue. I wonder what Sony is doing, if it's some kind of deliberate thing they're doing before shipping... –  MDT Guy Jun 21 '13 at 14:10
    
@Jaap: Is there any Sony proprietary power-management software running or any Sony provided power schemes active? If so try disabling it, restart and check. Also check if there is a UEFI/BIOS update available for the laptop. Also go into your UEFI/BIOS options, look through all power and especially ACPI related settings and try toggling them. (Don't worry, nothing bad will happen and you can always revert to defaults or to the original settings if you've noted them down.) This certainly seems to be an ACPI related problem, and if it's at the firmware level then obviously only Sony can fix it. –  Karan Jun 21 '13 at 16:09

4 Answers 4

up vote 2 down vote accepted

I just talked with Sony support and was told this for my particular model SVF14A15CXB. The air vent is situated such that closing the lid will interfere with the air flow. For that reason the option of closing the lid and doing nothing (leaving the machine on) is not an option. It was not left out by mistake. It was deliberate to avoid the machine overheating.

share|improve this answer

I used MDT 2012 U1 to install Win8-ENT on my lappie, and that seems to work just fine, so I know that option should be there, but then again, I didn't build SONY's image, god only knows what they've done to it.

THREE IDEAS:

  1. Try to Reset and restore the power plans to default:

    a. Click “Start”, type “cmd” in the “Start” search boxand hit ENTER.

    b. In the command prompt, type powercfg –restoredefaultschemes and hit Enter.

    c. Exit command prompt.

  2. Try editing the registry:

    HKLM\SYSTEM\ControlSet001\Control\Power\User\PowerSchemes

  3. As I noted earlier, I suspect this is something does on their models, if its fresh outa the box, just reinstall Windows, I'm sure this is something they did, if its a brand new computer, this helps get all that sony bloatware off.

share|improve this answer
    
reinstalling isn't an option anymore, computer is already set up and being used, the newest sony bloatware isn't as bad as it used to be, so I thought let's not go into trouble installing windows fresh. I've looked up DontSleep program which is actually better than completely turning off sleep. Thanks though! –  Jaap Jun 21 '13 at 18:09

I had the same problem with my new Vaio on Windows 8. The Vaio helpdesk confirmed indeed that this a Sony 'feature' but could not clarify why. They suggested to update to Windows 8.1; the problem should then be fixed.

Because downloading the 8.1 update from the Sony site failed I installed it directly from Microsoft. After the update the option 'no action' was available again.

However after an update from Vaio Update the 'no action' option was removed again! So the helpdesk was wrong by saying the issue was solved in Windows 8.1.

Inspired by the output of Powercfg /q I did some investigation in the relevant registry keys.

By adding the registry keys:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power\PowerSettings\4f971e89-eebd-4455-a8de-9e59040e7347\5ca83367-6e45-459f-a27b-476b1d01c936\3] "Description"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,\ 00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,\ 5c,00,70,00,6f,00,77,00,72,00,70,00,72,00,6f,00,66,00,2e,00,64,00,6c,00,6c,\ 00,2c,00,2d,00,35,00,30,00,2c,00,54,00,61,00,6b,00,65,00,20,00,6e,00,6f,00,\ 20,00,61,00,63,00,74,00,69,00,6f,00,6e,00,00,00 "FriendlyName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,\ 00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,\ 5c,00,70,00,6f,00,77,00,72,00,70,00,72,00,6f,00,66,00,2e,00,64,00,6c,00,6c,\ 00,2c,00,2d,00,35,00,31,00,2c,00,54,00,61,00,6b,00,65,00,20,00,6e,00,6f,00,\ 20,00,61,00,63,00,74,00,69,00,6f,00,6e,00,00,00

"SettingValue"=dword:00000000

the missing 'no action' option was available again (no reboot required)!

The value for 'Description' is: @%SystemRoot%\system32\powrprof.dll,-50,Take no action

The value for 'FriendlyName' is: @%SystemRoot%\system32\powrprof.dll,-51,Take no action

share|improve this answer
    
Nice fix but I'd be careful using it if - as another answer has it - there is an overheating problem. –  Chenmunka Nov 5 '13 at 14:21

Source: Windows 8: How to Lock (not sleep) laptop on lid close?.

There is no built in way to do this, but you could use LidLock for this purpose. It is a GUI tool which can help you what you want to achieve. You can also set it to start automatically with Windows start-up.

enter image description here

enter image description here

You can also set the timer for sleep/hibernate after locking the laptop.

You can read more about this on this article.

share|improve this answer
    
To the downvoters: explain why, as this is the best answer yet. –  harrymc Jun 22 '13 at 17:08
    
Hmmm it seems into right direction. ;) –  avirk Jun 24 '13 at 15:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.