Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a fresh install of arch Linux. I've installed Emacs from the rpos, and my home directory is mounted from a separate partition. I have old settings I've used on my ~/.ssh/config along with authentication keys I've regularly used before. Now, when I try to connect to a remote machine using Emacs, Emacs asks for my password and uses the wrong username. Clearly, Emacs doesn't access my config file. When I try to ssh or scp directly to the machine, things work fine. What do I need to update?

share|improve this question
    
This works for me. Are you sure that you use the same hostname as in the config file? –  legoscia Jun 19 '13 at 11:26
    
Yes. I've figured the problem. I had to update tramp default protocol. –  Yotam Jun 19 '13 at 12:15
1  
In that case, please post an answer explaining what you had to do and accept it. –  terdon Jun 19 '13 at 13:21
add comment

1 Answer

up vote 1 down vote accepted

Solved. Tramp default protocol was ftp and not ssh. I've updated it via Emacs gui setting interface and had to restart Emacs.

Edit:

M-x RET customize-option RET tramp-default-method

I remember I've changed ftp to ssh there but now I see scpc. Perhaps I've installed ssh after launching Emacs.

share|improve this answer
1  
This isn't a useful answer at the moment, but will be if you add some information on how you went about updating it. –  Aaron Miller Jun 20 '13 at 20:54
1  
Good edit! The scpc method uses the SSH ControlMaster option to establish an SSH connection and then reuse it for each SCP transfer, which is in my experience more efficient than establishing a new SSH socket for each transfer, as IIRC the ssh method does; you might want to give scpc a try -- after all, if it doesn't work, you can always switch back to ssh. –  Aaron Miller Jun 26 '13 at 15:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.