Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Windows 7 in English and I'm missing Central European characters in Notepad despite of picking "Central European" in [Format > Font... > Script].

In Windows 7 language settings I picked my country as region, date format, number format, keyboard etc. instead of the USA.

I installed Notepad++ and all symbols are present so they are missing in standard Notepad only. What needs to be re-configured?

share|improve this question
up vote 1 down vote accepted

By default the encoding option in notepad is set to save as ANSI and there is no way to set UTF-8 as default. This is by design. If you wish to save the file and change the encoding, you will have to manually set the encoding to UTF-8.

That is why I never use this program - e.g. UltraEdit, Notepad++ and so long are better ...

Take a look: http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/default-utf-8-encoding-for-new-notepad-documents/525f0ae7-121e-4eac-a6c2-cfe6b498712c

share|improve this answer
    
The strange thing is that before I re-installed Windows 7 I created these files in Notepad and they had Central European characters. I used the same Windows 7 DVD (it came with my laptop) to re-install my system today. Now all have turned. When I change encoding to UTF-8 without BOM in Notepad++ then it doesn't restore my characters, they become some unknown symbols. I think that there may be some system setting for that because all TXT files had these characters and they don't have them now :( – Paul Jun 19 '13 at 13:18
    
I had English Windows 7 with Central European keyboard and I used Notepad to write these symbols. Now they turned into something strange. I re-installed Windows 7 from the same DVD today. – Paul Jun 19 '13 at 13:27
    
I resolved this! Go to [Start > Control Panel > Clock, Language, Region > Change Location > Administrative > Change System Locale > Current System Locale] and pick your country there :) Now Notepad displays my characters and I still have Windows 7 Home Premium in ENGLISH like I wanted. Thanks!! [my Windows 7 was bought in the USA with Dell computer and they installed it in English for the first time] – Paul Jun 19 '13 at 13:34
    
Good job, Paul! :) – duDE Jun 19 '13 at 13:51
    
@Paul: You should add that as a separate answer so it's clearly visible to others. – Karan Jun 19 '13 at 21:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .