Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need x264 for my project.
I have one at /opt/local/bin/x264, but when I execute the following command:

x264 --qpfile cuepoints.qp --output output.mp4 input.mp4

it says:

x264 [error]: not compiled with MP4 output support

I decided to compile x264 from the source. I downloaded the source from http://www.videolan.org/ (git://git.videolan.org/x264.git).
Now I do:

cd x264
./configure --enable-mp4-output

And x264 says:

Unknown option --enable-mp4-output, ignored

And indeed, if I open configure file, there is no such option.

Finally, I could find compiled x264 with mp4 support (see here), but it is 3 years old and I need one more for Windows.

Do you know if x264 have dropped mp4 support, or I need to use a different option to compile it?

share|improve this question
1  
on a mobile device currently so can't properly check but from memory you need to download and compile GPAC then copy output into the x264 git folder before compiling in order to enable mp4. Doom9 / Doom10 forums might be a better place to look for specifics on the topic –  James Jun 19 '13 at 15:21

2 Answers 2

up vote 1 down vote accepted
+50

There is no --enable-mp4-output option. MP4 support is automatically detected, but l-smash or gpac are required.

For a script that might compile x264 see HOWTO: x264.
For another example see Compiling X264 on Ubuntu.
Also see the FFmpeg and x264 Encoding Guide.

share|improve this answer

Have a look at https://astrataro.wordpress.com/category/encode/x264/ which provides modified builds with mp4 and audio enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.