Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to turn off Compatibility Mode for IE. I do not want to disable it.

For example, setting the following key to 9999.

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION" /v "iexplore.exe" /t REG_DWORD /d 9999 /f
REG ADD "HKEY_CURRENT_USER\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION" /v "iexplore.exe" /t REG_DWORD /d 9999 /f

This overrides the settings.

I have also found that via GPO: Admin Templates > Windows Components > Internet Explorer > Compatibility View > Turn off Compatibility View does the same thing.

I just want it to be OFF by default, and the user has control to change it.

It would also be nice to grey out the option: Display all websites in Compatibility View

share|improve this question
    
@nixda thanks for fixing my post! I'll do a better job moving forward. please excuse the noobness. – Paul Mung Jun 20 '13 at 16:27
up vote 1 down vote accepted

I used procmon to figure this out.

I was hoping for a solution in HKLM... but unfortunately this is a user preference.

HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation" /f /v AllSitesCompatibilityMode /t REG_DWORD /d "0"
HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation" /f /v IntranetCompatibilityMode /t REG_DWORD /d "1"

So the way i would execute this is:

for /d %%X in (C:\Users\*) do (
reg.exe load HKLM\TempHive "%%X\NTUSER.DAT"
Reg Add "HKLM\TempHive\Software\Microsoft\Internet Explorer\BrowserEmulation" /f /v AllSitesCompatibilityMode /t REG_DWORD /d "0"
Reg Add "HKLM\TempHive\Software\Microsoft\Internet Explorer\BrowserEmulation" /f /v IntranetCompatibilityMode /t REG_DWORD /d "1"
reg.exe unload HKLM\TempHive )

I have to do a force log off to make sure the users NTUSER.DAT is not loaded. In my testing i had to run it at the logon screen.

Any other thoughts on deployment would be appreciated.

share|improve this answer

Paul,

I encourage you to check into using the Active Setup key.

In short, you can add a self-generated GUID to either:

HKLM\SOFTWARE\Wow6432Node\Microsoft\Active Setup\Installed Components, or HKLM\SOFTWARE\Microsoft\Active Setup\Installed Components,

depending on your architecture.

Within this GUID key, add the following values:

(Default) REG_SZ <A name for your task>
Version REG_SZ <A version number for your task>
StubPath REG_SZ <The command you want each user to run>

Each user will run the command in the StubPath value once at logon. On subsequent logons, Windows will check the version number the logging-in user last ran against the Version key; if the Version key is higher the user will re-run the StubPath string.

share|improve this answer
    
We try to avoid short links here because the user doesn't know what the destination of the link is until he/she clicks through it. – bwDraco Oct 2 '15 at 19:05

Just found this and noticed you didn't have an HKLM answer, so I'll provide what worked for me:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\BrowserEmulation]
"IntranetCompatibilityMode"=dword:00000001
share|improve this answer

FYI, this does not work via HKLM, in my experience. I had to change this setting on a bunch of Citrix servers.

What worked for me, since we wanted to disable this for all users, current and new, was to load the default profile, rather than individual user profiles, and edit the HKCU hive. We also wanted to disable compatibility mode on intranet sites.

Thanks to Paul Mung for raising both the question and the answer in this thread!

HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation" /f /v AllSitesCompatibilityMode /t REG_DWORD /d "0"

HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation" /f /v IntranetCompatibilityMode /t REG_DWORD /d "0"

share|improve this answer
    
You say you're loading the default (user) profile, but I don't see you doing it. – G-Man Aug 4 '15 at 6:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .