Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have compiled custom kernel for my Arch. It's not the first time i'm doing it, but this is the first time that i can't see any text output during boot. While compiling the kernel i have unchecked many "framebuffer" items and i think it's related to that. All i see during the boot is just "blob" of white dots on top of the screen, and that "blob" seems to change (like system is trying to output something but can't). I'm sure it's something trivial (like "turning off this / that module would cause that") but i can't really tell on my own. What is the problem, and what module is used for outputing boot text before my Nvidia driver loads up?

share|improve this question
2  
Does it boot successfully or is it stuck? Are the "blobs" text, or could this be a plymouth theme? Could you post a screenshot? What are your grub options? Are you setting quiet at the kernel's entry in grub.cfg? –  terdon Jun 19 '13 at 20:53
    
It's ok, it doesen't stuck. I don't have a plymouth and i can't tell if it's text or not, it's like "attempt" to form some text (judging by the fact that all dots are white). Regarding grub options - it's the same with or without "quiet" kernel parameter. –  guest86 Jun 19 '13 at 22:54

2 Answers 2

up vote 0 down vote accepted

Maybe it's a framebuffer resolution problem, try this in the /etc/default/grub file to let GRUB detect the good framebuffer resolution

GRUB_GFXPAYLOAD_LINUX=auto

Or try to force GRUB to use normal mode

GRUB_GFXPAYLOAD_LINUX=text

Or try to force GRUB to not use framebuffer

GRUB_TERMINAL_OUTPUT=console

Don't forget to generate the config file after changing GRUB options

grub-mkconfig -o /boot/grub/grub.cfg
share|improve this answer
    
The "console" thing did the trick! Now, it's just a problem that resolution is too low but i guess that this information can tell you what module i have to bring back into kernel right? :) –  guest86 Jun 21 '13 at 18:23
    
I will accept your post as it lead me to the cause: i had to re-enable "Vesa" kernel module :) –  guest86 Jun 21 '13 at 20:20

Have you tried the nomodeset kernel parameter?

I haven't compiled a custom kernel, but I've encountered similar-sounding symptoms on boot several times, and adding nomodeset has usually helped.

share|improve this answer
    
Tried, no help :) –  guest86 Jun 20 '13 at 16:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.