Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having a pain getting this fixed...

I dont really know how it happened, I suspect it was related to CCleaner, but can't be sure. I went to mount an .iso file and got an error saying something to the like of "No application has been setup for this file type" - While thats not the 100% exact way it was said, that is what it mean.

Now, I also noticed that the icon had changed, and instead of being Daemon Tools Lite icon, it was another icon, akin to the windows "I can't find your icon" icon.

Now, at first I couldn't even go "Open With", and thus I restored the backup CCleaner made, as I had just ran it for the first time since my laptop's HDD had died (about a month or two back)

This let me set the "Open with" to Daemon Tools. But, now I get from Daemon Tools "Error in Command Line". Looking around on my computer, this has affected all files normally opened with Daemon Tools.

How can I fix this? I know somewhere there is a... "thing" for setting the file extensions and their association, but I cant find it, and its really being a pain


Now, here's something I've found - If I go into Daemon Tools, and tell it to be the file association with .isos, it will cause windows to go back to asking what program I want to open with. Something strange is going on.

Also, I have tried reinstalling Daemon Tools

share|improve this question
Have you tried simply (uninstalling and) reinstalling Daemon Tools? – Karan Jun 20 '13 at 2:05
Ah yes, I have. No dice. Will put that in the question – Gareth Jones Jun 20 '13 at 2:06
Try uninstalling DT (you have to manually remove the SPTD driver), then go to the registry and delete all its associated extensions from HKEY_CLASSES_ROOT. Now reinstall and see what happens. Edit: Ah, I see from your self-answer below that it helped. – Karan Jun 20 '13 at 2:15
Yes. The link I posted was where I got the answer from, but had I seen your comment first, I would have tried it – Gareth Jones Jun 20 '13 at 2:20
Hardly matters, as long as it's fixed. :) – Karan Jun 20 '13 at 2:27
up vote 0 down vote accepted

This issue relates to (At a guess) a corrupted RegEntry!

At the very least, the fix is simple.

Follow the instructions here:

Which I will quote:

  • running regedit
  • delete HKCR.iso DAEMON.Tools.Lite, delete it
  • delete HKCR\DAEMON.Tools.Lite
  • Run Daemon Tools Lite, untick integration, Apply, retick integration, Apply

Fix it, and now its running fine

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .