Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a url that I'm hitting that works in incognito mode, Firefox, Safari, and pretty much any other browser other than vanilla Chrome. If I curl the url, it returns 200.

For whatever reason, Chrome is caching an old redirect for the url. I've tried completely wiping all cache and history to no avail.

How do I fix this and is there anything else I can do to test why this is happening?

share|improve this question

migrated from stackoverflow.com Jun 20 '13 at 5:30

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

Suggestions:

1.Add a unique suffix to the URL, this will avoid the cache. Example: Original URL http://google.com, change it to http://google.com?Hello=1 or http://google.com?Hello=2

2.Use Chrome built in Developer tools and watch the newtwork tab

share|improve this answer
add comment

As it turns out, I use a chrome extension called HTTPS Everywhere which comes with rules about how to redirect certain sites to the secured version. In my case, HTTPS Everywhere was matching a Formstack url I was trying to access and incorrectly redirecting it to the wrong url.

There is a bug in the rules for Formstack which incorrectly redirects:

This: http://www.formstack.com/forms/?abc-123

To this: https://www.formstack.com/forms/forms/?abc-123

Here's the incorrect rule:

Ruleset Path: /Users/MYUSER/Library/Application Support/Google/Chrome/Default/Extensions/gcbommkclmclpchllfjekcdonpmejbdp/2013.6.4_0/rules/default.rulesets

<ruleset f="Formstack.xml" name="Formstack (partial)">
    <target host="formstack.com"/>
    <target host="*.formstack.com"/>
    <exclusion pattern="^http://www\.formstack\.com/forms/$"/>
    <rule from="^http://(www\.)?formstack\.com/" to="https://$1formstack.com/forms/"/>
    <rule from="^http://blog\.formstack\.com/favicon\.ico$" to="https://www.formstack.com/favicon.ico"/>
    <rule from="^http://(?:blog\.formstack\.com/wp-content/themes/fontstack-theme|support.formstack.com/assets)/images/bg\.jpg$" to="https://www.formstack.com/assets/images/bg.jpg"/>
</ruleset>

To fix, change this line:

<rule from="^http://(www\.)?formstack\.com/" to="https://$1formstack.com/forms/"/>

To:

<rule from="^http://(www\.)?formstack\.com/" to="https://$1formstack.com/"/>

After updating the rule, simply disable and then disable the extension and it should take effect right away.

I'm not sure why the exclusion pattern didn't match for my url, but nevertheless, the fix above works for me. If I get some time, I might submit it back to the project.

Hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.