Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I plug in a flash drive Windows sees the drive but when I try to access that drive shows that it is unformatted. I've tried at least four kinds of flash drives and all have the same problem though those work perfectly in another PC with the same OS.

I've tried to format two of those flash drives and Windows gives an error of format. I've tried in front and back USB ports, and got the same problem. A printer is working in one of the USB ports.

How can I access the content of these drives on my own PC?

share|improve this question
    
Thanks for edit. I'm sorry for all grammatical errors :S –  Danixu Jun 20 '13 at 15:40

2 Answers 2

There are a lot of things that can cause RAW/unformatted warning issues with flash drives.

First of, try plugging the drive into another PC, backing it up and reformatting it then connect (the now empty + reformatted) drive into the problem PC.

If that doesnt work, open disk management, if your disk is listed in the window under volumes, select it and see if the memory view shows a healthy allocated partition. If it doesnt you, can use this information to do some more relevant searching on Google as again, it may be a lot of things, but there is plenty (like, tons) of already answered questions on forums about such.

If you still have a problem, open device manager and look down through the list of devices under the headings disk drives, storage controllers, system devices and, most importantly, universal serial bus controllers. If any of them show icon overlays such as yellow question marks or exclamation marks or red x's your problem is likely with the device driver (if not with the device itself). Again armed with this info you should be able to find plenty of info to solve via Google - the usual root being to use the windows wizard to either fix or uninstall and then re-install the driver - though you should be careful that you understand which driver you are uninstalling and why before you do so as you could end up bricking your system.

share|improve this answer

If you are using Windows based system, Please check once with SAFE mode. It will detect and ask for resolve without formating. In linux,ubuntu you can access directly even if your disk is in RAW.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.