Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Slackware 14 and I installed flash player as in this blog post http://goo.gl/A0Yxf. According to which I simply copied the "libflashplayer.so" provided by Adobe to the firefox plugin directory and it was working perfectly.

So when new Firefox versions came I installed a new version following the steps in this post http://goo.gl/HOJVd and I did the same steps to install flash player. I didn't remove the old firefox installation. The problem is that if I am use the link to the old firefox I can use the flash player but else new installation doesn't recognize the flash player installation.

Can anybody tell me what I have done wrong here.

share|improve this question
    
Where did you put the plugin? In your $HOME/.mozilla/firefox/<PROFILE NAME>/plugins directory? There are various "plugin directories" for firefox. The post you linked to is how you installed thunderbird, could you show us the actual commands you ran to install firefox? Did you also link it to /usr/bin? Where is the other firefox instance installed. The more infor you give, the likelier it is we will be able to help you. –  terdon Jun 20 '13 at 14:42
    
@terdon 1. I put the plugin in "/usr/lib64/firefox-*/plugins". 2. Yes, I installed the firefox in the same way, actually I don't have the commands as installed it one month ago. 3. Yes, I linked firefox to '/user/bin'. 4. in '\usr\lib64\firefox-15.0.1\'. Thanks –  abhips Jun 20 '13 at 16:51
    
Does it work if you save the plugin in your $HOME/.mozilla/firefox/<PROFILE NAME>/plugins directory? –  terdon Jun 20 '13 at 17:31
    
@terdon seriously I haven't checked that, I'll try it out and let you know. :) –  abhips Jun 20 '13 at 17:33
    
@terdon, Found the solution :). link, actually your comments lead me to the idea to research about plugin directories for firefox. Thanks a lot for your time and effort :) –  abhips Jun 20 '13 at 18:26
show 1 more comment

1 Answer 1

up vote 1 down vote accepted

As per the post "Installation of flash player for Slackware 14" you just have to copy the

'libflashplayer.so'

to '/usr/lib64/firefox-*/plugins/' (for 64 bit slackware) or '/usr/lib/firefox-*/plugins/' (for 32 bit slackware) but in Firefox 21 it is '/usr/lib/firefox-*/browser/plugins/' or '/usr/lib64/firefox-*/browser/plugins/' depending upon if OS is 32 0r 64 bit.

So problem solved by copying the 'libflashplayer.so' to appropriate directory

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.