Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I mistype a URL, Chrome sometimes redirects me to a search. For instance, typing "example_url_i_sometimes_mistype.conm" into the location bar gets me:

Your search - example_url_i_sometimes_mistype.conm - did not match any documents.

Not only is this annoying, but if the mistyped URL was one on private DNS, I've now just told Google that the domain exists. (A small concern, but bad in principle.)

Can I configure Chrome to just show an error and not blab to Google Search about it?

share|improve this question

3 Answers 3

In Chrome -> Settings -> Show Advanced Settings in the Privacy section, untick

Use a web service to help resolve navigation errors

Chrome navigation error

You can also tweak Chrome's omnibox settings by going to the URL chrome://omnibox

share|improve this answer

Create a search engine which sends the query to the browser instead of Google.

  1. Right-click the Chrome omnibar and select Edit search engines
  2. In the Other search engines area click on the first blank field and type in the following values into the three columns: s             %s           http://%s

Define new search engine to redirect query to server url

  1. Hit tab to save this new entry
  2. Hover over the entry and click Make default
  3. Click Done to exit the Search engines panel

Any words typed into the Chrome omnibox are passed to the browser directly prepended by http:// forcing Chrome to treat one or more words as a server url.

The drawback is that in order to search from Chrome you need to prefix search terms with a keyword. The benefit is that Chrome never tries to search. A search must be done explicitly.

The result of this can look strange due to the Chrome policy of not showing http:// in the urlbar. If a server can not be found then Chrome will throw a This webpage is not available error message.

share|improve this answer

I think you'll need to turn off search from Omnibar then...I'm not sure how Chrome could distinguish from a mistyped url from any other search.

Look at the privacy options in the settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.