Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Apple have made an interesting headphone port for the MacBook (and some other Intel Mac models). It works like a standard jack:

  • nothing plugged in -> audio comes out of built-in speakers
  • headphones/external speakers plugged in -> plays through headphones/external speakers

but you can also use a special adapter (which trips a tiny microswitch) to get an optical audio out signal (which you can presumably plug into a nice surround-sound system).

This is all well and good except when, like auto-tracking, it doesn't work, and you are left with nothing to adjust. Users report that they get no sound when they have nothing plugged in and that a red light emanates from the headphone port. If you go to System Preferences -> Sound -> Output, it will say (IIRC) "Optical Out" instead of "Internal Speakers".

The only solution I'm aware of is to try to reset the switch by inserting and removing a set of headphones or a toothpick, perhaps wiggling it inside of the port, and hoping that you luck out and get it.

Are there other ways to fix this problem? Does anyone know where the microswitch is or have a good technique to reset it?

share|improve this question

migrated from Oct 26 '09 at 18:17

This question came from our site for system and network administrators.

iPhone users have reported a similar problem, when the device thinks that headphones are attached even when they are not. The solution is the same .. use a toothpick or paper clip to toggle the switch. Apparently the problem is more acute when using 3rd party headphones. – tomjedrz Oct 26 '09 at 16:19
This is probably better suited to – Izzy Oct 26 '09 at 16:29
I felt it was relevant here as, as a Mac admin, I've seen the issue come up several times. – Clinton Blackmore Oct 26 '09 at 17:35
It's not organized so much around the role of the person as the role of the machine. The idea is to concentrate workstation-specific issues to SU, but it's easy enough to migrate. ;) – Kara Marfia Oct 26 '09 at 18:17
up vote 6 down vote accepted

I've used toothpicks or half of a Q-Tip - really, anything non-metallic that will fit - to do a counter-clockwise sweep of the inside of the opening with success. I've seen various reports as to where the switch may be; I typically just sweep until it's fixed. If you have iTunes open and playing or the Sound PreferencePane of System Preferences up you'll be able to tell when you've hit the switch.

share|improve this answer
+1 excellent idea -- especially the part about having the audio playing while doing it. – Clinton Blackmore Nov 19 '09 at 15:47
While this works I don't always have a something like a toothpick or Q-tip lying around to do this. I put my headphones in at an able and that works. – CR47 May 23 '14 at 14:18

Toothpick and/or plugging and unplugging regular headphones worked for (I was doing both, not sure which did the trick, but I bet it was the toothpick).

share|improve this answer
This just repeats what the OP mentioned in the question. It does not add a solution. – fixer1234 Apr 17 '15 at 20:43

I tried the toothpick, and couldn't get it to work. (I was probably doing it wrong.)

However, after reading this thread, I tried plugging my headphones in, then pulling them out slowly while jiggling the headphone plug. This fixed it straight away.

share|improve this answer

I'm going to share my last-resort solution. You may no longer be able to use headphones, but you will get your speakers back.

I've tested this on a 15-inch Macbook Pro 2012 (non-retina). It may or may not work on other models. The Macbook Pro I tested this on was stuck on optical audio after the jack was damaged removing a broken connector.

The solution is to create a short-circuit between these two pins on the logic board (at the right of this image):

enter image description here

How you do this is up to you. I was successful using a small piece of wire and some electrical tape as a short-term solution, and eventually ended up soldering it in.

Do not attempt soldering on your logic board if you do not have experience soldering small electronics. Make sure no other components are shorted. You risk causing even more damage.

Do not hold me responsible if you destroy your logic board.

share|improve this answer

Plug in your headphones, (they will work) now turn off the computer. Remove the headphones and turn on the computer.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .