Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen lots of folks having problem with **hardware reserved" memory issue in Windows 7/Server 2008 R2. I have it myself but not as huge as others have.

Problem description

When you install Windows 7 (or its bigger brother Windows Server 2008 R2) your memory may not be fully utilised. If you look at

Task Manager >
    Performance Tab >
        Resource Monitor >
            Memory Tab

And scroll to the bottom of the list you will see a graphical representation of your memory. Some of it may be hardware reserved. Previous Windows versions didn't have this problem. System was able to utilise all memory available.

Question

Is there any solution to lower/remove hardware reserved memory?

Sidenote

I tried installing 32 and 64 bit versions but to no avail. I also tried both Windows: 7 and Server 2008 R2. But always get the same amount reserved by HW. On previous Windows versions I had more memory available because I'm simultaneously running 2 VMs on host (so three machines all together). And my memory peaks much higher now as it did on older versions.

My issue

My computer is HP nc8430 notebook with Intel T7200 processor, 4GB memory and 320 GB hard disc. It has an ATI Radeon Mobility X1600 graphics card with dedicated 256 MB of memory. And I'm running Windows Server 2008 R2 x64 at the moment. I'm getting 641 MB of harware reserved memory in any of the upper sidenote described configurations.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

The hardware reserved memory has nothing to do with Windows 7/Server 2008 R2, it's just that earlier versions of Window's didn't point it out to you this clearly. On my work laptop Windows 7 shows 31 MB of system reserved and when I was running Windows XP, (looking closely I can't remember where), it showed that I had 4064 MB available (when I had 4096 MB installed).

You will have to examine your hardware to determine the cause of the reserved memory, but I doubt there is anything that you can do.

Edit based on hardware description:

According to HP your laptop has an Intel 945 chipset. That chipset only does 32bit addressing so you won't be able to use all 4GB of your RAM, since some of that address space is reserved for hardware IO. Even running 64 bit Windows, you're stuck with 32 bits of hardware address space because of the chipset

share|improve this answer
    
I'm sure my memory wasn't lower for 641 MB as it is now. Some users are stating half the memory as they have actually have which is ridiculous. –  Robert Koritnik Oct 26 '09 at 18:47
    
Wow, that's quite a bit. It's probably still something hardware related. Want to update your post with hardware details –  shf301 Oct 26 '09 at 18:51
    
I've read some people with 4GB of memory had 2GB as hardware reserved that is REALLY concerning. But I'd still rather use my 641 MB for my VMs. Because running three machines simultaneously I'm practically running on 3.9... –  Robert Koritnik Oct 26 '09 at 18:53
    
According to HP (hp.com/hpinfo/newsroom/press_kits/2006/mobility/…) Your laptop has an Intel 945 chipset. That chipset only does 32bit addressing so you won't be able to use all 4GB of your RAM, since some of that address space is reserved for hardware IO. Even running 64 bit Windows, you're stuck with 32 bits of hardware address space because of the chipset –  shf301 Oct 26 '09 at 19:16
    
Interesting. As far as I can remember I was able to use all 4GB in Windows Server 2008. But it's true I'm not 100% sure... –  Robert Koritnik Oct 26 '09 at 22:03

"MSCONFIG > Boot > Advanced Options"

Thanks for reminding me!

I had maxxed this out while on Vista and after upgrading to Windows7 it had somehow been reset to "0". Unchecking the box fixed it for me. Before, over 4Gigs of 8Gig total were shown as "Hardware reserved memory" and I was getting BSOD. Now it is sitting at 10MB. I'm still not so sure it wasn't an update that broke my machine as it had been working fine for a few weeks.

share|improve this answer

Simply switching the RAM modules solved this very same problem for me.

Before:

  • Memory slot #1: 1 GB module
  • Memory slot #2: 2 GB module
  • Installed 3 GB, usable about 1.75 GB (0.25 GB graphic card, 1GB hardware reserved)

Now:

  • Memory slot #1: 2 GB module
  • Memory slot #2: 1 GB module
  • Installed 3 GB, usable about 2.74 GB (0.25 GB graphic card, 0.01 GB hardware reserved)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.