Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have deleted everything that I could from my browser history:

chrome://settings/clearBrowserData

I checked everything and select the begining of time

Then when I access browsing history:

chrome://history/

There is nothing (as I expected), or to be precise No history entries found.

The problem is that I still see my specific search url with very specific query I have made a month ago, when I start typing the url of the website into chrome address bar.

How is that possible? Where is Google stroing these data. How to get rid off them completely?

I want to mention that my autosuggestion options look like this:

enter image description here

So, what else should I delete to remove everything from autosuggestions?

Right now it has some specific URLs (subpages, pages with very specific search query I have made in a month or so).

I have tried restarting Chrome and restarting my computer, but the urls are still in the autosuggestion.

Also I am unable to turn off the autosuggestion, even I have unchecked that option in settings.

My Google Chrome version is: Version 27.0.1453.116 m (probably the latest)

Btw. in Firefox deleting the history works as expected. So, I guess that this has nothing to do with the operating system I am using (Windows 7), but only it's an issue with Chrome itself.

share|improve this question

2 Answers 2

Disconnect your Google account in Chrome's Settings

Disconnect Google account

Exit Google Chrome.

Re-start Google Chrome and sign in again using your Google account.

Having cleared the settings, Google Chrome will still automatically suggest search terms based on popular queries, but does not take your past browsing history into account.

Chrome Omnibox

Clean Uninstall

To completely remove Chrome from Windows, uninstall Google Chrome from Add or Remove Programs.

Then proceed to delete the following folders

  • %userprofile%\AppData\Local\Google\Chrome
  • %userprofile%\AppData\Local\Google\Chrome SxS
  • %userprofile%\AppData\Local\Chromium

Re-install Google Chrome again.

share|improve this answer
    
I have tried this already, but without success ;( –  Derfder Jun 25 '13 at 21:04
    
@Derfder do you mean the autocomplete still works, similar to my 2nd screenshot? –  hanxue Jun 25 '13 at 21:09

This is a problem I couldn't replicate. I cleared all my browsing history since the beginning of time, and Google Chrome doesn't show any of my previous URLs.

However, you could be having an issue with Google Web History.

enter image description here

You may have to go in and clear your history there. You also probably want to turn it off, it gets pretty annoying.

If that doesn't work, you probably have malware.

share|improve this answer
    
My https://history.google.com/history/delete?hl=en&btnD is empty too but it doesn't effect anything ;( . Also, I don't understand why Google Chrome is always autosuggesting even I have turned it off. –  Derfder Jun 21 '13 at 17:45
    
I tried to use CCleaner, it doesn't help either ;( –  Derfder Jun 21 '13 at 17:57
    
Did you try MalwareBytes? You get one free scan, and it once solved a problem I had with text in Firefox hyperlinking to random sites. –  Lincoln Bergeson Jun 21 '13 at 17:59
    
I have malwarebytes, nod32, spybot but everything is ok. I don't think it's a virus. The links are to normal sites and are specific e.g. to where I make comments, my specific query etc. I was thinking that I will re-install Chrome, but reinstalling chrome every time I want to delete urls seems weird. –  Derfder Jun 21 '13 at 19:42
1  
The malware is called Chrome, its one of big G's primary spytools. –  JKAbrams Dec 18 '13 at 8:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.