Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had success altering about:config in firefox to get firefox to work with certain intranet sites that use windows integrated security. Is there something like about:config in Chrome? Is there some other way to change a setting to enable windows integrated security (NTLM) in Chrome?

share|improve this question

migrated from stackoverflow.com Oct 26 '09 at 20:14

This question came from our site for professional and enthusiast programmers.

7 Answers 7

To summarize the link provided by @Vivek Kodira, you can to set a proxy server on your local machine that will do the authentication on behalf of Chrome. Then it's not Chrome that does the authentication, it's the proxy, but Chrome doesn't know that.

share|improve this answer

Chrome has been updated (version 5+) has the following:
In windows it integrates with intranet zones setting in 'internet options'

In Windows only, if the command-line switch is not present, the permitted list consists of those servers in the Local Machine or Local Intranet security zone (for example, when the host in the URL includes a "." character it is outside the Local Intranet security zone), which is the behavior present in IE.

If a challenge comes from a server outside of the permitted list, the user will need to enter the username and password.

For other OS's, you can use the command line switch:

--auth-server-whitelist="*example.com,*foobar.com,*baz"

source: https://sites.google.com/a/chromium.org/dev/developers/design-documents/http-authentication

share|improve this answer

well it's a known problem... it should be fixed in future versions...

http://code.google.com/p/chromium/issues/detail?id=19 http://code.google.com/p/chromium/issues/detail?id=6824

share|improve this answer
    
Google is working on it right now in the issue tracking systme –  James Oct 1 '09 at 15:18

It's scheduled for inclusion in Milestone 5:

http://www.chromium.org/developers/design-documents/network-stack

share|improve this answer

Googling produces a few links that suggest otherwise. The first result however (link) suggests a hack. Hope it is useful:).

share|improve this answer

I've found out that some proxy servers (Websense in my case) have configurations concerning the user-agent. And they actively block NTLM auth even when requested by the browser if the user-agent is not recognized (or matches some list, dunno). For example in my company, setting chrome's user-agent to a Firefox user-agent magically makes NTLM authentication work. I suggest everyone having NTLM auth problems to try changing their chrome's UA to the one of a working browser (IE ou Firefox) and see if it works. If it does, blame your company's sysadmins for doing this.

share|improve this answer

Help get this fixed: go to Google-Chrome known issues and report that you are having this issue also.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.