Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC was working fine last night. It was previously a perfectly stable, well protected and carefully maintained Windows XP SP3 system. After shutting down then restarting, Windows gets to the XP logo screen (with the blue progress meter) but then generates this error just before displaying the login/welcome screen (or just reboots if restart-on-failure is enabled):

STOP: c0000135 {Unable to locate component} This application failed to start because winsrv was not found. Re-installing the application may fix this problem.

I tried booting into Safe Mode, Last Known Good etc. All boot modes result in the same error. Safe Mode gets to mup.sys before the STOP occurs. I installed a fresh copy of Windows XP on another drive that's in the PC, updated to SP3, and that boots up just fine. So I don't think this is a hardware related failure. Even so, the motherboard is new. The power supply is new. Two of the 4 memory sticks are new. The only other component is an Nvidia graphics adapter (7800 GTX).

I thought the problem might be registry related, so I followed the steps described by Microsoft in repairing a corrupt registry here:

http://support.microsoft.com/kb/307545

This basically involves booting to Recovery Console, copying the backup registry files in the windows\repair folder to the windows\system32\config folder, rebooting and then restoring a previous version of the registry from a System Restore point. It did not work. I got the exact same error.

I tried googling for a few hours now but nobody seems to have a solution to this or even any definitive explanation about what causes it. Not even Microsoft. :/

Has anyone encountered this or figured out a solution to the problem? Does anybody know what winsrv.dll is/does or how it's used by Windows? Is there any way to determine what "application" is being referenced in the error code that's actually failing? I tried "boot logging" hoping Windows would generate some useful debug information, but it just listed the drivers it was able to load or not load. Totally useless. Frankly it's pretty stunning that Windows can't even boot up to a basic functioning state. Never had a problem like this in almost 20 years using various Windows editions.

Anyway, any and all input is much appreciated.

Thanks.

p.s. As noted in the comments below, I already tried replacing winsrv.dll. It was not missing though, unless there are supposed to be multiple versions in multiple locations, but that doesn't seem sensible or likely.

share|improve this question
    
It sounds like you have corrupt system files likely caused by a failing hdd. Because Safe Mode does not work unless you have a system restore point from a working configuration you are likely out of luck. You can try to replace it using the recovery console: answers.microsoft.com/en-us/windows/forum/windows_xp-system/… –  Ramhound Jun 22 '13 at 2:57
    
Is it possible to know which files might be affected? What's linked to winsrv.dll (ie what uses or depends on it)? What does Windows use to start up? Chkdsk did correct some errors in one of the dozen or so reboots - it reported missing indexes and some rather cryptic messages - but it reports no errors now. It logged what it fixed, if that's worth pasting here. I can access the drive fine as a secondary device and read files off it, so that doesn't seem to be the problem. It's also about a year old so it seems unlikely that it would be failing. –  jsmith Jun 22 '13 at 3:20
    
And BTW, not sure why you down voted this question. As I mentioned in the main post, I've googled the issue and looked at many many forum posts, knowledge base articles, etc across various sites including this one. There's only ONE other article on these boards that deals with this issue and it remains unresolved. That's why I resigned myself to posting the question here. I already saw the link you provided to answers.microsoft.com, but it didn't provide any meaningful insight. Replacing winsrv.dll was the first (and rather obvious) thing I did, to no avail. If it was that trivial ... –  jsmith Jun 22 '13 at 3:26
    
First I didn't downvote your question. Second you didn't mention that Chkdsk detected disk errors and basically deleted system files. As I suspected your missing a required system or at the very least its corrupt. have you ran a sfc /scannow on through the recovery console? I won't be coming back to this question, I wish you luck. –  Ramhound Jun 22 '13 at 15:11
    
Thanks for the tip Ramhound. I haven't run sfc so maybe it will reveal something. I was looking into the Master File Table thinking a system file record may have gotten corrupted. RE down voting, you were the only respondent so I assumed (sorry) that it was you who down voted. Mea culpa. –  jsmith Jun 23 '13 at 16:45

1 Answer 1

You probably have some type of hardware or disk hardware error. Have you checked your event log? In any event, you have the option of restoring your system from those fine backups you have been keeping....you do have these right? OR - a total re-installation from scratch. I'm not sure with the little information or even with more information any of us would be able to assist you.

You could, of course, try M$ support and maybe they have a better answer.

BTW, XP support ends 1 April 2014, you should consider moving on to another later Windows version like 7. Or if you are really daring win 8. Of course you will have to update all your applications.

share|improve this answer
    
I tried reading log files but if I'm looking at the right ones, they're binary and not readable with a generic file editor. Not sure how to view them outside of windows event viewer. I'll have to look into that. Thx –  jsmith Jun 23 '13 at 16:48
    
I'm still not certain what the problem is but for the sake of posterity, I figured I would add a comment here about where I am with this. At this point, I suspect that there was some sort of corruption of the Master File Table which was exacerbated by Chkdsk. I'm going to try "repairing" the windows installation using a "slipstreamed" XP recovery disc. –  jsmith Jun 25 '13 at 18:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.