Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to make a live USB of OpenSUSE on my new Thinkpad laptop, but none of the windows tools I was trying worked. I put in a Live CD of Ubuntu 12.04 and tried to used the "dd" command to write the image to the USB drive. Unfortunately, I mistyped the command, and overwrote the MBR and part of the C: partition of the hard drive. I realised this almost imediately after running the command and stopped it with Control+C.

I rebooted the computer and was greeted with this error:

ISOLINUX 4.04 0x513118db EHDD Copyright (C) 1994-2011 H. Peter Anviv et al
Unknown keyword in configuration file: )╪x£i
Unknown keyword in configuration file: ╓─
Unknown keyword in configuration file: %[_
Unknown keyword in configuration file: {
No DEFAULT or UI configuration directive found!
boot: _

It seems that the boot loader from the OpenSUSE image was copied before I stopped dd.

I went back onto the Ubuntu LiveCD and took a look at the partitions with GParted. There were three tiny partitions, and the rest of the 500GB hard drive was not partitioned. I decided that I needed to fix the MBR, and used TestDisk to do this. It seems to have done that job ok. This is what I now have on my hard drive:

  1. BOOT, a 4 megabyte fat16 partition
  2. 1.46 gigabytes of unallocated space
  3. Windows7_OS, a 450.62 gigabyte ntfs partition
  4. Lenovo_Recovery, a 13.67 gigabyte ntfs partition
  5. 1.02 megabytes of unallocated space.

It seems that the first 1.5 gigabytes of my C: drive has been erased, but that Lenovo's Recovery partition is still unharmed. At this point, I assume that recovering the Windows 7 system files from where they are is impossible, and I will have to copy them from somewhere else.

Before I did any of this, I created a Lenovo Rescue and Recovery disk for my laptop. This is supposed to allow me to restore my laptop to factory condition from the Lenovo_Recovery partition. I booted from the disk and this is what happened: http://imgur.com/a/szAhS

I looked at the contents of the Lenovo_Recovery partition with the Ubuntu Live CD. It contains two *.wim files: cdrivebackup.wim and sdrivebackup.wim. It seems that these are the restore files that I need to put into action, but I have no idea how to use them.

So, this is where I stand. How can I restore Windows 7 to my partially reformatted laptop? If you need more info, please ask!

share|improve this question
    
Why don't you just download a copy of Win7 and use it instead? You'll have to download all the relevant drivers on another PC of course (or at least the network driver so you can get online to download the rest). –  Karan Jun 23 '13 at 1:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.