Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My keyboard's input characters place is changed. When I click to Shift+2 button to write @ character, it writes " character. When I click to Shift+" buttons, it writes @ character. It writes £ character instead of #, and # character instead of \. What is the problem and how can I solve it? My OS is Windows 7.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Probably your keyboard layout is changed. To check the keyboard layout

Windows 7 or Windows Vista

     1. Click Start , type intl.cpl in the Start Search box, and then press
        ENTER.
     2. On the Keyboards and Language tab, click Change keyboards.
     3. Click Add.
     4. Expand the language that you want. For example, expand
        French (Canada).
     5. Expand Keyboard list, click to select the Canadian
        French check box, and then click OK. In the options, click View
        Layout to compare the layout with the actual keyboard. In the
        Default input language list, click French (Canada) – Canadian
        French, and then click OK two times.
     6. In the Regional and Language
        Options dialog box, click OK. 
        **Note :** The Language bar appears on the
        taskbar. When you rest the mouse pointer over this bar, a tooltip
        appears that describes the active keyboard layout.Click the Language bar, 
        and then click FR French (Canada).

So as given in the example, you can change the layout to your needed layout. This should solve your problem.

share|improve this answer
    
no, my language layout is English and is normal. But only some characters aren't in their own place. –  Ziyaddin Sadigov Jun 24 '13 at 4:38
    
Can you check if keyboard type is changed, like 'United States-DVORAK' –  abhips Jun 24 '13 at 6:27
    
where is keyboard type? –  Ziyaddin Sadigov Jun 24 '13 at 7:23
    
Ok, thanks, I solved problem, I did how you explained, again did it, and solved, I changed my main language from EN(United Kingdom) to EN(USA), and solved, thansk! –  Ziyaddin Sadigov Jun 24 '13 at 7:28
    
You are welcome :), glad to know that my answer was helpful. Happy computing :) –  abhips Jun 24 '13 at 9:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.