Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have had this iMac for a couple of years, and I have had constant issues with the wifi periodically disconnecting (only recently cared because I have actually started using it). I have recently upgraded to OS X Mountain Lion and that hasn't seemed to solve the issue. My Linux and Windows Machines that are right next to the iMac have never had any issues with wifi dropping out. What could be the problem here? I honestly do not like macs so I have never spent any time on them and therefore don't know much about how they work, so please keep that in mind when answering.

I have attempted to search it, and it does seem to be quite allot of issues with this, but no answers (at least not in the first 20 pages of most forums).

share|improve this question

This happens because the channel of your wifi router is the same as other routers in your neighborhood. follow the steps below and you will be sorted. 1. System preferences > advanced > wifi >delete your saved wifi. 2. Delete all your saved wifi passwords from keychain 3. Go to the router setup from another computer AND CHANGE THE CHANNEL. For router with 2.4 Ghz band, set the channel to 3 or 4. For router with 5Ghz band, set the channel to 36 or 42. Some routers have both the bands. Change both. 4. Connect back to your router. Thats it!

share|improve this answer
What does the keychain have to do with this? – lzam Sep 29 '14 at 2:20

I had some problems with WiFi on my MacBook (Lion) (mine didn't even recognized the network) and did a lot of research on it. There are a couple of typical things suggested for solving issues like this. I did almost all of them and somehow the problem was solved, but I'm not sure which one worked! So, I just list them. Check either one of them and see if the issue is solved or not.

  1. Go to System Preferences -> Network: remove the WiFi interface from the left list and then add a new one.
  2. System Preferences -> Network: Create a new location (at the top) and use it for connecting. For some, this has solved the dropping problem.
  3. Go to Network -> Advanced -> TCP/IP and click Renew DHCP Lease.
  4. If neither of the above worked, this solution may solve it: Resolving Stubborn Wi-Fi Connection Problems in Mac OS X. (Also, check the comments on the above site. Some have suggested other solutions.)

So, these were the things I can think of that may help solving the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.