Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Windows 8 installed, and tried to install Xubuntu in another HDD on my desktop. After installation, I could only boot into Xubuntu, and never got into the OS selection menu in GRUB. So I ran Boot Repair in order to fix the boot problems.

The boot process got fixed, now it does boot into GRUB, where I have two Windows entries, but none of them actually work, I get the error:

error: no such device: 1CA0-4000
error: file 'EFI/Microsoft/Boot/bkpbootmgfw.efi' not found

I've tried to run the Windows 8 installation again, and chose Automatic Repair, but it was not able to correct the problem. So I guess the EFI files in the windows EFI boot partition of the 1st disk got deleted/chaged. How do I get them back/fix the windows bootloader?

I'm doing all of this with UEFI boot, both in the OS installed on the disks, and the installation media (booting from a USB flash drive).

share|improve this question
    
Please run the Boot Info Script and post a link to the RESULTS.txt file that it produces. –  Rod Smith Jun 24 '13 at 20:22
    
Found the answer [here][1], following the instructions in @Alex answer. [1]: superuser.com/questions/460762/… –  joaocandre Jun 27 '13 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.