Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem similar to what is described at "Why is my USB mouse disconnecting and reconnecting randomly and often?" except is is happening in both Windows 7 and Linux (Ubuntu 12/04TLS, fully patched), multiple mice, multiple OSs. It stops responding to input for about 3-5 seconds, then starts responding again. It's more frequent and lasts longer when running games (TF2, L4D, Dishonored, Borderlands 2, and more), but happens when just running the OS as well.

I was hoping it was the motherboard so I bought a USB 2.0 PCI card to try that, but it's still happening. I've stripped it down to just the keyboard and mouse (different keyboard too just in case the keyboard was the problem), but it's still happening. All the hardware (mice and keyboards) work fine on other computers. I have literally pulled the mouse and keyboard out and plugged them into another computer (laptop) and re-joined the online game and had no problem with the keyboard and mouse combo that just failed on my gaming rig.

Please no driver / Windows or Linux only suggestions, as that wouldn't effect both OSs.

edit: known good mice I've brought home are now going bad. I suspect the hardware is messed up (voltage?) and has been frying the mice.

share|improve this question
    
Strange. Perhaps try a wireless mouse? –  Keltari Jun 26 '13 at 3:43
    
An Ubuntu fileserver that I maintain is prone to this, despite nobody touching the console for weeks at a time. Every minute or so, the "PixArt Microsoft USB Optical Mouse" disconnects and then reconnects as the next higher-numbered device. Fills up the log files a treat. –  Camille Goudeseune Apr 16 at 17:31
add comment

1 Answer

XP 32bit Logitech wired mouse

My mouse disconnect frequency multiplied 4x when i plugged in two external hard rives. I've done this before w/o issues.

None of the previous tips helped, this is how i fixed it & it worked!!
I went to the device manager, expanded mouse.

There were two HID mouses listed; one was Logitech & the other was "compliant mouse" I disabled the "compliant mouse" & left the Logitech one alone.

Mouse is fantastic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.