Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running:

  • OS X 10.8
  • U.S. English as the default system language
  • a German (Austrian) keyboard layout

Via RDP (specifically the Remote Desktop Connection client 2.1.1 from Microsoft), I'm connecting to:

  • Windows 8
  • German (Austrian) as the default system language
  • a German keyboard layout (as seen in the screenshot)

Unfortunately, the keyboard layout appears to be English in Windows, meaning, when I type y I get z, and when I type - I get a /, et cetera.

I assume the problem is on the Windows side of things, as I've never had issues before, even with RDP connections. Unfortunately, I have no idea what to change or what to tell Windows, since it should actually run just fine.

What can I do?

share|improve this question
up vote 0 down vote accepted

It appears that despite the settings in the Windows Control Panel, another keyboard layout was set in the task bar:

Changing this back to Deutsch (Österreich) fixed the keyboard layout.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .