Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running into some problems when mounting my SMB share using the /etc/fstab file. Mounting the share with the mount command works just fine:

    mount -t cifs //hostname/dir /mnt/dir -o  user=myUser,pass=myPass,
ro,file_mode=0777,domain=mydomain.hh,_netdev

But when I try to create an entry in the fstab file:

//hostname/dir   /mnt/dir cifs    user=myUser,pass=myPass,ro,file_mode=0777,domain=mydomain.hh,_netdev      0       0

it does not mount during boot. Do you guys have any idea? I'm on Linux 3.6.9 on an ARM Processor and the mount command is from busybox 1.21.

share|improve this question
    
I put a script in /etc/network/if-up.d/ so it would run when the network is up. this works, but I thought the _netdev option would do this? –  tzippy Jun 24 '13 at 10:12
    
(1) Do mount //hostname/dir and mount /mnt/dir work? (2) Do the other entries in /etc/fstab (the ones that successfully mount at boot time) have auto in the options field (user=…,pass=…,ro,…)? Try adding that to this one. –  Scott Jun 29 '13 at 0:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.