Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a blank site running in IIS, bound to port 80 HTTP traffic. This sits behind a router that port-forwards HTTP traffic to my server. Publicly I have a domain registered and use FreeDNS.Afraid.org as my dynamic DNS provider to point at my router. This is working, I can see my site publicly.

Also on my router, I am port-forwarding Plex's assigned port to the same port on my server. This is also working, I can manually find the Plex web page via mydomain.com:<plex port>/web.

I have a sub-domain registered that is in the format plex.mydomain.com where my regular domain is www.mydomain.com. On FreeDNS I can successfully point plex.mydomain.com to my blank web page.

What I am trying to do is have IIS listen for requests to plex.mydomain.com and route them to either localhost:<plex port>/web or mydomain.com:<plex port>/web.

I installed the URL Rewrite module and created a standard rule for redirecting based on matches with the word "plex" in it, this didn't work. I attempted to log what was happening using Failed Request Tracing; I got log files but they didn't mention any attempts to rewrite the URL.

I installed Application Request Routing, but this won't let me specify a port number. I have yet to try adding a new application to IIS that represents the Plex server.

How can I route requests to plex.mydomain.com to mydomain.com:<plex port>/web?

I haven't got access to my server currently (but can provide the URL Rewrite configuration if necessary). Also, my experience with IIS and deployment is limited so pardon any contradictions I've made, if any.

I believe this is IIS Express on Windows 8 Pro.

share|improve this question

migrated from serverfault.com Jun 24 '13 at 12:15

This question came from our site for professional system and network administrators.

    
And the last sentence is where it all goes wrong I'm afraid; we really only deal in server-level software here (so, IIS8 on Server 2012, not express on Windows 8). I'm going to move this over to Super User for you where you might have better luck. –  Mark Henderson Jun 24 '13 at 12:15
    
@MarkHenderson Excellent thanks, wasn't sure about the exact location of this. I reviewed SuperUser beforehand but deemed the IIS part more relevant for ServerFault. My bad. To be honest, I didn't review the ServerFault help beforehand so I missed the "not about home set-ups" part. –  Adam Houldsworth Jun 24 '13 at 12:19

1 Answer 1

may be help ...

Creating Rewrite Rules for the URL Rewrite Module

HTTP Redirects

share|improve this answer
    
I'm not usually a fan of link answers. The first link I have exhausted, but I haven't encountered the second link. I will give that a go tonight. I originally looked for HTTP Redirect in the IIS management console, but I presume now that I haven't got that module installed / enabled. –  Adam Houldsworth Jun 24 '13 at 14:48
    
@AdamHouldsworth In the worst case, you can change the page by default, which will be engaged in forwarding the rules. –  STTR Jun 24 '13 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.