Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have replaced my MacBook keyboard twice and I continue to have the same issue. When I press the ] n } key it just turns on Caps Lock. I really need these keys to code.

Can anyone help me with this?


share|improve this question

migrated from Oct 26 '09 at 22:45

This question came from our site for professional and enthusiast programmers.

Does this happen with both external keyboards and the built-in keyboard, or just one or the other? – Stephen Jennings Oct 27 '09 at 0:28
Does this happen for other user accounts on your machine? Does this also happen when you boot from your Mac OS X DVD, during setup? – Daniel Beck Apr 13 '11 at 19:48
I don’t know enough about Macs, but I would assume that they too support multiple keyboard layouts, especially on a laptop. It sounds like a different layout has been accidentally selected. Someone with more Mac knowledge would need to explain how to choose the keyboard layout (hotkey? ‘control panel’ applet?) and probably how to remove the other ones. – Synetech Feb 1 '12 at 23:49

You should install PCKeyboardHack and change the keycode of the capslock key to 30 (keycode of "]" button). Next you have to switch off caps lock in keyboard settings.

share|improve this answer

The problem I find with a MacBook keyboard is that I can hit the caps lock key when I'm typing fast or carelessly (usually instead of the A key, sometimes instead of the left shift key). Could your trouble be that with the '}' key, you hit the caps lock instead of the shift key just below it? That doesn't explain the problem with the ']' key.

What is your language and keyboard settings set to? Have you accidentally done something with the keyboard shortcuts from 'System Preferences' / 'Keyboard and Mouse'?

share|improve this answer
Note that in Snow Leopard, the preference pane you want is simply titled "Keyboard". – Wuffers Dec 7 '10 at 0:01

You must log in to answer this question.