Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run XAMPP server on my Windows XP. If I try to access to http://localhost or http://127.0.0.1 it gives me this error:

Could not connect to remote server

This only occurs if my Comodo firewall is turned on. I turned off the firewall and everything worked perfectly. The problem isn't about the Comodo Defense+ because it is still on. The problem must be with the firewall, because if I trun it off everything is ok.

I still can ping both http://localhost and http://127.0.0.1 even if the firewall is turned on.

I tried to set http://127.0.0.1 fully enabled both in the Aplication Rules and Global Rules tab in the firewalls Network Security Policies settings, but didn't changed anything.

What is the problem?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I found the solution:

I blocked some time wasting sites in the .hosts file like this:

127.0.0.1 example.com www.example.com

For "double protection" I also blocked example.com in the Comodo firewall's Blocked Zones tab in the Network Security Policies settings, thus the firewall blocked example.com that was redirected to 127.0.0.1 in the same time. After deleting the blocked addresses from the Blocked Zones tab everything works correctly even if the firewall is turned on.


I neither blocked directly localhost in the .hosts file, nor in the firewall. However indirectly I blocked localhost in the firewall because I blocked sites that were redirected to localhost. If I disabled the firewall only the redirections were active, so eg. if I typed example.com it redirected to my local server. When the firewall (and the blocks too) were enabled then they blocked localhost thought the blocked example.com.

The problem was not in the settings of the .hosts file and (kinda) not in the blocks in the firewall because I used both of them frequently. I just didn't thought they will affect eachother. In addition you only notice this conflict in some specific cases like mine: you have a server, and want to acces it through localhost.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.