Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a recent asus motherboard with an i7 processor and i've got a nvidia 670gtx connected to it.

For various reasons/experimentation purposes i'd like to connect my monitor to the intergrated graphics adapter rather than my gtx 670 card.

If i connect it to the motherboard's DVI connector the screen does not display any image on POST, nor when i'm actually in my OS, if i move the connector to the GTX card i get an image however.

Why is this happening? how can i use the intergrated graphics port to connect my monitor? (it must not involve disconnecting the GTX card)

share|improve this question

marked as duplicate by Journeyman Geek, mpy, AthomSfere, gronostaj, tombull89 Jun 26 '13 at 8:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Try disconnecting the gtx 670, then plugging into the onboard adapter, if there is still no change, update the post. –  user88311 Jun 25 '13 at 0:51

1 Answer 1

There is likely an option in the BIOS that you can adjust to force the integrated GPU to be used by default.

I selected a board at random on ASUS's website (the new Z87-DELUXE) and looked through the manual. The setting you need to adjust appears to be Primary Display which is located in Advanced > System Agent Configuration > Graphics Configuration on this new board. By default, Primary Display is set to Auto; to force the integrated GPU to be used as the primary display output, select iGPU instead.

If you cannot locate this setting in your board's BIOS take a look through the BIOS section of the manual; it can easily be found on Asus's website if you do not have the booklet anymore.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.