Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I open Windows Explorer and enter an IP for a computer on my home network (\\192.168.1.101). It takes 30 seconds or more to present a list of the shared folders. It does not appear to be an initial handshaking/authentication thing; even if I allow the view to load and then immediately load the same again, it is always slow.

Once they appear, navigating through folders and opening files is fast. Also, navigating directly to a folder (\\192.168.1.101\My Music) is fast, even if it's the first connection since a restart.

Using \\computerName instead of the IP address gives exactly the same results.

Pings return in 1ms.

net view \\computerName (or \ipAddress) returns the list of shared folders fast. This makes me suspect an Explorer issue rather than a network issue.

Suspecting that the remote computer was being automatically indexed or something, I went into Tools->Folder Options->View and unchecked "Automatically search for network folders and printers," but that made no difference.

De-selecting the "Folders" icon near the address bar makes no difference.

Adding the IP address and computer name to the hosts file makes no difference.

Both computers involved are laptops running Windows XP. Both have WiFi and cable adapters. Mine is not connected via cable. The result is the same whether the target is plugged in to the cable or not (although the IP address changes - 192.168.1.101 over cable, 192.168.1.103 over WiFi.) We are using DHCP assigned by the router.

share|improve this question
    
I've always been wondering about this too. –  ephilip Oct 27 '09 at 17:08
    
+1 good question. also need good answer –  metal gear solid Apr 18 '10 at 8:20
    
Try using a program like Total Commander and check if the accessing is faster. It should be –  Drake May 28 '10 at 16:14

7 Answers 7

I've seen this happen before and it was a NETBIOS name issue (can happen even if you use the IP) -- try adding the computer name to your HOSTS file and see if it still happens.

  • Open Start > Run
  • Run "notepad c:\windows\system32\drivers\etc\hosts"
  • Add "192.168.1.101 ComputerName" to the file

Not sure why this happens unless maybe Windows tries to match the IP address to a NETBIOS hostname.

Of course it could be another issue but this is something easy/quick to try.

share|improve this answer

Here is an article with a bunch of workarounds to check :

Slow network browsing in Windows XP

share|improve this answer

If it is also fast when you close the explorer window and reopen the machine, I would say that this is nothing to worry about.

It takes time the first time because your computer is basically handshaking, exchanging security settings, logging on etc.

Sometimes when I connect to a remote machine for the first time in my session, it can take a good 10-20 seconds to log on. After that, it is fast and there is no problems.

Again, I would say at this point, there is nothing to worry about.

share|improve this answer

This is a long shot: is your desktop dual-homed? That is, does it have two active network interfaces? A wireless interface counts. If this is the case, then the network services might be trying to reach that IP over both interfaces (and waiting for the wrong one to time out) before showing you anything. It can be especially problematic if both interfaces are eventually part of the same network (e.g. a laptop connected via a cable, but also with a wifi connection to a hub on the same LAN).

You can try running net view \\192.168.1.101 from the command line. If that returns instantly (and you haven't already "primed the pump" via explorer), then I would suspect something to do with your view settings in Explorer, which I will answer separately.

share|improve this answer

If you have the "Explorer Bar -> Folders" enabled, turn it off before you do the steps you describe. Otherwise you are forcing Explorer to show you the Windows network structure when all you really want is the list of shares.

share|improve this answer

As it seems it isn't suggested yet:

  • "Control Panel"
  • "Internet Options"
  • "Connections" tab
  • Click "LAN Settings" button
  • Untick "Automatically detect settings"

That's what sped up network share browsing for me. Additionally, there are some registry tweaks that can be done to improve it further, however I cannot remember the details.

share|improve this answer

Another longshot, make both computers member of the same Workgroup. In SystemProperties>ComputerName>Change.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.