Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I click on "Send link" in Firefox, a window that looks like Internet Explorer pops up and tells me that my default mail client isn't properly installed. The mail client, which is set as default) is Thunderbird.

I tried searching the rest of the internets without any success.

  • Yes, I have tried to set the default mail client with the utility included in Vista, but had no success.
  • No, this does not seem to be related to either Firefox or Thunderbird. At least that bit I learned from my googling. Others are having the same problem with IE and Windows Mail.
share|improve this question

3 Answers 3

up vote 1 down vote accepted
+100

What I could find was:

Setting Firefox's mail client

  • At the top of the Firefox window On the menu bar, click on the Tools Firefox Edit menu, and select Options... Preferences....
  • Select the Applications panel.
  • Search for the Content-type: mailto and select it.
  • Click on the Actions column in the mailto row, to change the action.

    alt text

  • Always ask will prompt you each time you use a mail function for which program or service to use.

  • Use (default) will automatically launch your operating system's e-mail program (e.g. Thunderbird, Outlook, Entourage, Evolution) to its message composition window.
  • For instructions on how to change your operating system's default e-mail program, see the next section of this article.
  • Use will open your webmail service's (e.g. Yahoo! Mail, Gmail, Hotmail) message composition page inside Firefox. For more information about using webmail services, see the Using webmail services section of this article.
  • Use other... will let you specify an external program for Firefox to launch.
  • Application Details... will let you view information about or remove the webmail services that Firefox can use.

Click OK to close the Options window

Click Close to close the Preferences windowClose the Preferences window

Or read this:

The default mail client is the program that opens when you click a link in another application to send a mail message, for example, when you click on a mailto link or when you click File -> Send link" in Firefox. Note that the default mail client is not as much of an issue when using Mozilla Suite/SeaMonkey because the browser and mail components are integrated (e.g., a mailto link in a SeaMonkey browser window should open SeaMonkey Mail, regardless of your default mail client).

This article describes how to configure Thunderbird as the default e-mail client. However, you must also configure any other e-mail clients you run to not attempt to be the default e-mail client or it will have no effect. For example, in Outlook Express you may need to press a button in "Tools -> Options -> General -> Default Messaging Programs" to make the dialog box say "This application is NOT the default mail handler". Note that the calendar in Outlook will not work unless Outlook is the default email client.

You do not need to make Thunderbird the default email client in order to send/receive email. It's used mainly to allow other applications to use Thunderbird to send a message by making SimpleMAPI calls (if your operating system supports MAPI) , or by your clicking on a mailto: URL (in a browser). It also associates Thunderbird with the .EML file extension under Windows (if you're running 1.5 or later) so that if you double click on a .EML file its displayed in Thunderbird.

Note: If you receive a message such as Firefox doesn’t know how to open this address because the protocol (mailto) isn’t associated with any program. that means that no mail client is currently set as the default and you will need to set one.

In Thunderbird, go to "Tools -> Options -> General" and select "Use Thunderbird as the default mail application". (In the Mozilla Suite, go to "Edit -> Preferences -> Mail & Newsgroups" and select "Use Mozilla Mail as the default mail application".) If that doesn't take effect right away, try restarting Thunderbird or even the computer once.

If that still doesn't work then another email client (such as Outlook or Windows Mail) is probably also configured to be the default email client. If you're using Windows Vista go to "Start -> Default Programs -> Set Program Access and Computer Defaults" and set "Mozilla Thunderbird" as your default e-mail application. See this article at msdn.microsoft.com for more information.

If you're running Windows XP another solution would be to download the DefaultMail utility and use it to set the default e-mail client. It can also do this on a per-user basis. That's useful if several people share a machine (with their own Windows user account) and each wants to use a different e-mail client as the default e-mail client. If none of these methods work it might be because your windows account doesn't have the rights to modify the registry. Try using the "run as" command to temporarily run a command/application as a administrator.

share|improve this answer
    
Thank you! That finally did the trick. –  innaM Jul 23 '09 at 19:58
    
Sweet! :D Good to hear it worked –  Ivo Flipse Jul 23 '09 at 20:00

You mention that you've tried setting Thunderbird as the default mail client using Vista's utility, but have you tried doing it from within Thunderbird itself? I don't have Thunderbird here at work, but I believe the General tab of the options dialog allows you to do this.

Apologies if you've already attempted this method, but I'm pretty sure this is how I set Thunderbird as the default mail client on my Vista-based laptop.

UPDATE: Just found this thread, which seems to describe the same problem as you're having. First it suggests changing your default mail client to be Windows Mail, then putting it back to Thunderbird to re-attempt the required registry changes for the association. If that doesn't there is further discussion of editing the registry directly. Hope it helps!

share|improve this answer
    
Yes, I tried this. Thunderbird is even set to check whether it's the default client each time it starts. But it was worth a try. Thanks for your answer. –  innaM Jul 20 '09 at 11:35
    
I am sorry to report that the trick of changing default mail clients didn't work for me. I will have to unearth the registry information now. But to be honest, when I first googled the problem and found forums like that, I thought: Thank god for superuser.com. Hmm. Now it's back to those forums. –  innaM Jul 20 '09 at 18:35
    
Sorry to hear you're still having trouble. I hope the registry tweaks in that thread help! –  BenA Jul 20 '09 at 19:01
    
Any update on your progress? –  BenA Jul 22 '09 at 14:09
    
Yep. Thanks for asking and sorry to tell you that Ivo hit the jackpot. –  innaM Jul 23 '09 at 19:59

Try the steps in this link, but choose Thunderbird as the program instead of GMail.

If that doesn't work, can you click on regular mailto: links? I believe the issue is with the handling of mailto: - Windows doesn't know that there's a program able to handle it.

share|improve this answer
    
I will try this if you tell me the Thunderbird URL. –  innaM Jul 16 '09 at 20:10
    
It might well be that Windows doesn't know how to handle mailto links. What I'm looking for is a way to teach it how to handle them. –  innaM Jul 16 '09 at 20:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.