Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Acer Aspire R7, and I'm happy enough with it except for the way Acer handles the Auto-Rotate Lock.

Auto-Rotate in Windows 8

Normally in Windows 8 if you rotate the physical screen, a sensor notices, relays that to the sensor service, and the display rotates to match. You can turn this on or off either by right-clicking the Desktop, hitting Screen Resolution, and toggling the checkbox "Allow screen to..." or by swiping in from the right to get the "Charms" (eugh naming), tapping Settings, then Screen, and tapping the rotate icon at the top of the brightness slider.

How the Aspire R7 screws this up

Shortly after Windows 8 boots, software somewhere on the machine boots (about the timing of a Delayed Start service, but I am yet to find such a service...) and you see the "Auto-Rotate Lock On" notification appear at the top-right of the screen. If you fold the screen all the way down into Tablet mode you see another notification, "Auto-Rotate Lock Off," and you're now able to rotate it 90 degrees etc.

This causes 2 problems:

  1. Overwrites user settings If you explicitly go in and set auto-rotate lock on or off, it's not long before this rogue service or process overwrites this value with what it thinks it should be based on the current placement of the screen.

  2. Screws up the display It's pretty easy during transition from Tablet mode to end up with the Auto-Rotate Lock On notification coming up while the screen is rotated oddly - for example 90 degrees. The screen is then locked there until you manually go in and fix it. You can do this by taking the steps above to access the normal auto-rotate settings, and the screen will fix itself before Acer gets a chance to overwrite your setting.

I'd like to disable the software causing this problem, but I can't determine which Service or Process or Startup entry I need to kill to pull it off. Has someone else figured this out?

Useless Customer Service Message for the Curious

For the curious I have filed a ticket with Customer Service, which cannot be linked to here, so here's a copy/paste of their useless answer:

Dear ,

Thank you for contacting Acer America. I apologize for the inconvenience that you have experienced. This feature is required for screen operation in various modes and should not be disabled. The image on your screen can be rotated with Windows Mobility Center using the keyboard or touchpad. Touchscreen input will only be accepted in Touchpad mode.

Respectfully, Acer America Online Technical Support

Notably this isn't even for the right laptop - the touchscreen works in all modes on the Aspire R7.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Preventing the EZel Sensor Service from running, by either setting it to Manual or Disabled, and restarting, fixes this issue.

Start key, type Contr to search for Control Panel, tap Administrative Tools, double-tap Services, scroll down to EZel, right-click, Properties, set to Manual or Disabled. Click OK and it will stop bugging you on next restart.

Disable EZel Sensor Service

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.