Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to delete all files/dirs named .svn using rm on cgywin

drwxr-xr-x    6      4096 Oct 26 15:33 .svn

$ rm -d .svn
rm: cannot unlink `.svn': Not owner
share|improve this question
up vote 1 down vote accepted

If you are the adminsitrator on your machine, ownership is a concept that shouldn't concern you much.

Do chmod u+w .svn, then try your remove again.

share|improve this answer
not sure that'll work on cygwin. may need cacls (if administrator) to get permissions on the file. – quack quixote Oct 27 '09 at 5:18
@~quack. Thanks - You may be right - I think there is a dependency with the CYGWIN environment variable ( I may have forgotten about. – DaveParillo Oct 27 '09 at 22:56
The CYGWIN variable needs to include a setting for ntea (NT Extended Attributes). This should be done in the file cygnus.bat. Add the following line in the file: export CYGWIN=ntea – DaveParillo Oct 27 '09 at 23:01
good find, but actually i think you want ntsec not ntea (same link, further down the page), to get real permissions instead of faked. more here: ... – quack quixote Oct 28 '09 at 4:53
Good catch. Thank's for keeping me honest! – DaveParillo Oct 28 '09 at 15:10

super-user (root) is the only account able to use rm -d flag

From the rm man page

-d, --directory

      unlink FILE, even if it is  a  non-empty  directory  (super-user
      only; this works only if your system supports ‘unlink’ for 
          nonempty directories)

You will need to su root or something similar before using rm -d

Have you tried rm -rf /full/path/to/dir or (if empty) rmdir /full/path/to/dir ?

share|improve this answer
+1 for rm -rf. – paulroho Sep 19 '14 at 19:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .