Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Seagate FreeAgent GoFlex external drive and I've always used with the eSATA cable. However, today I connected the drive to save some files but it didn't let me, always showing a "write protected" error.

I tried everything I found on the internet, mainly to clean attributes and take ownership (it complains to be write protected). Then, I connected the drive with a USB 3.0 cable and it worked!

Does anyone know why is that happening and how to solve it? I really need to use the eSATA cable because the USB one is not mine.

Thanks!

share|improve this question
up vote 0 down vote accepted

It seems that the cable is defective. I tried to connect another GoFlex with the same cable and I got the same issue. As USB 3.0 is working fine and eSATA cable for GoFlex is discontinued, I'm staying with the USB.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .