Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows pops up the "Unable To Load Component" warning whenever any program starts. The DLL is netexmls.dll which I can't find anywhere in the registry or on google. Most programs still load once the warning is cleared and run as normal though some won't run at all, Firefox, chrome, paintbrush.

If I place a different DLL in the system32 folder I get a missing procedure call which is also non existent on google or in the registry.

This also happens when I boot into safe mode. I have tried sfc /scannow and a couple of system restores but to no avail.

I am at a loss as to how to stop it. Any suggestions?

Warning Message

share|improve this question

migrated from stackoverflow.com Oct 27 '09 at 3:29

This question came from our site for professional and enthusiast programmers.

    
You should post this at superuser.com. This is not programming related. –  gatorfax Oct 27 '09 at 3:19
    
thanks i believe someone else has done that for me already though. Cheers –  Will3265 Oct 27 '09 at 3:35

1 Answer 1

up vote 2 down vote accepted

Is the dll listed by autoruns?

If not, you might try running dependency walker on an app that causes the warning and see if it shows up there.

share|improve this answer
    
I tried autoruns and it does not come up in there. I will try dependancy walker now... –  Will3265 Oct 27 '09 at 3:50
    
using dependancy walker I found that imm32.dll had an extra function added to it which called upon the missing dll. I replaced the dll with the imm32.dll from another xp machine and it works now. Thank you Sean –  Will3265 Oct 27 '09 at 4:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.