Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I am trying to give another PC completely unrestricted access to my machine. They are both on the same subnet. What I am looking for is effectively disabling the firewall entirely for one IP address.



Client: Firewall "off"

World: Firewall "on"

To be specific I am running "Easy"PHP as a testing server for websites and want to access them from other machines on my network. After tinkering I figure the method suggested in my question would be best to make things actually easy.

PS. I have already tried opening all ports both inbound and outbound to that IP with no results. My only current success has been actually turning the whole firewall off.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Scott Chamberlain, gronostaj, soandos, Mokubai Jun 29 '13 at 9:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

This is essentially… with a range of one IP :) – Squeezy Jun 26 '13 at 15:43
@Foo_Chow Follow the answers for this question just select allow instead of block… – Ramhound Jun 26 '13 at 15:43
@Squeezy not even close to a dupe. That is what I tried in the PS. section. Didnt work. Im looking for complete disabling to one IP. – foochow Jun 26 '13 at 15:59
You can not disable it for one IP, however accepting ANYTHING for that IP should not result in the firewall blocking traffic anymore. Please show the configuration you attempted. – Squeezy Jun 26 '13 at 16:02
You are configuring the firewall on the host, please set Local IP address to any, and remote IP address to the one you want to give access. The configuration in that screenshot is valid, but useless. You have essentially configured access TO and FROM the same IPs. – Squeezy Jun 26 '13 at 16:15
up vote 3 down vote accepted

At host (Windows 7)

incoming Firewall Off:

netsh advfirewall firewall add rule name="Firewall Off IP Incoming" dir=in action=allow protocol=ANY remoteip=

outcoming Firewall Off:

netsh advfirewall firewall add rule name="Firewall Off IP Outcoming" dir=out action=allow protocol=ANY remoteip=

logging firewall dropped packets:

netsh firewall set logging droppedpackets = ENABLE

Install telnet client and check remote application:

telnet <service port>

Check whether the current user is an administrator in the domain:

dsquery * -filter "(&(objectCategory=person)(objectClass=user)(name=%username%)(adminCount=1))" -attr name

Check whether the current user is an administrator on the local machine:

wmic NETLOGIN  Where (Caption="%username%" AND Privileges=2) get Caption, Name, NumberOfLogons, PrimaryGroupId, BadPasswordCount
share|improve this answer
+1 for netsh. Also I love the term "outcoming" :D Please mention this needs to be done from with privileges. – Squeezy Jun 26 '13 at 16:18
Honestly I have no clue why this doesnt work for me. It clearly should, but I guess EasyPHP is messing with something... Not easy in the slightest – foochow Jun 26 '13 at 16:32
Ping works though. So at least the communication barrier is down – foochow Jun 26 '13 at 16:35
@Foo_Chow, unless the IPs are wrong for your environment it definitely should. You can try logging drops as specified in to see why your traffic is dropped. Maybe that will show you what is happening. – Squeezy Jun 26 '13 at 16:36
@Foo_Chow what say telnet <service port> ? – STTR Jun 26 '13 at 16:57

Not the answer you're looking for? Browse other questions tagged .